Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok I just got myself a new macbook pro and loving it. I'm trying to set it up as a dev environment.

I'm trying to get my basic phpinfo to work. I installed php from the venerable Marc Liyanage (http://www.entropy.ch/software/macosx/php/#install) When i make a dummy php file called test.php with the phpinfo(); code in it, apparently running http://localhost/~username/test.php should show me something. But i get absolutely nothing. Google chrome throws me a big fat "This webpage is not available".

I'm presuming there's something fundamental i'm missing. The web service should start up on it's own according to install. I even went to System Preferences > Sharing > and made sure Web Sharing is checked. It provides me with the link as well and says that your website...available at the the "Sites" folder. I have placed the test.php in the Sites folder as well.

I'm clueless now, anyone kind enough to help troubleshoot a newb's problem?

Cheers K

share|improve this question
    
where are you save your test.php code? – Am1rr3zA Jul 16 '10 at 20:42
    
I'm saving it in the "Sites" folder in my user directory. – Kaushik Gopal Jul 17 '10 at 5:39

If Apache isn't up, start it up:

  1. System Preferences
  2. Sharing
  3. Web Sharing
    • Check the little box.

Try it again and see if you get anything.

share|improve this answer
    
Hey Jack, i already tried that, after enabling the little inbox, it also gave me the exact url i should be clicking to access my website etc. I simply appended my test.php to the end of that url and tried. but couldn't get anything. – Kaushik Gopal Jul 17 '10 at 5:41
up vote 0 down vote accepted

Ok so it happens, the entropy distribution i had initially used for PHP+Apache isn't supported on Snow Leopard. Apple Snow Leopard now comes by default with latest versions of php and apache. For more info you can check this link http://www.entropy.ch/phpbb2/viewtopic.php?p=14856#14856 to the entropy forums.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .