Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Ubuntu 10.04 installed on my system. When I am logged on locally I have excellent sound.

If I make a second login as a different user ssh -X other@localhost that user cannot get audio.

When I try to run mplayer I get the error message

AO: [pulse] Init failed: Connection refused
Failed to initialize audio driver 'pulse'

Should I ssh as the console-user, everything works fine.
I suspect that somehow I should enable pulseaudio for this second user, however I don't know how to do this.

/L

(If someone wonders why I do this, I am experimenting with having different account for dedicated tasks. Like banking, youtubeing, etc.)

share|improve this question
up vote 2 down vote accepted

I found the answer, there are some pulseaudio settings in Pulseaudio Preferences that are needed. However that is not installed by default in Ubuntu 10.04.

 sudo apt-get install paprefs
 paprefs

(paprefs also available System -> Preferences -> Pulseaudio Preferences)

Enable "Network access to local sound devices".

/L

share|improve this answer

Well ... I don't know about Ubuntu, but in Mandriva Linux there is a setting in the sound configuration called "Enable user switching for audio applications" which makes what you are asking for. Unfortunately I don't know how to set this in console or in Ubuntu.

You could also try to disable pulse and use only alsa and see if it's working that way.

share|improve this answer
    
Yes, I suspect there is something like that. I just cant find it. – leiflundgren Jul 17 '10 at 19:37
    
Sorry, I can't help you more ... I'm not a big fan of Ubuntu. However here are a few tips I found with google: - try looking for a setting with policykit - try disabling pulse and using ALSA which should have this setting enabled by default – Patkos Csaba Jul 17 '10 at 21:41
    
Thanks for the help, it gave me an idea on which track to search along. /L – leiflundgren Jul 19 '10 at 8:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .