Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I press the " or ' keys (apostrophes), I need to press another key for the character to appear on the screen.

If I press " twice in a row, there appear two "-s but only after second key press.

If I press " once, nothing appears on the screen. As soon as I press a subsequent key, the " appears together with the subsequent key.

Same behavior with the ` key.

I initially thought this was a setting in Visual Studio I set somewhere by mistake - but now I noticed this is happening computer-wide in any application.

What is happening here? How do I set the keys back to their normal function?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

This is related to your keyboard settings. Go to the keyboard settings and change the Keyboard from US international to US.

In case you cannot remove the US international keyboard, you must unmake it your default one and then remove it.

share|improve this answer
    
Thanks. Now I feel very dumb :) I have reinstalled the system 2 months ago and only now did I notice I chose the wrong keyboard layout. –  Marek Jul 17 '10 at 13:17
add comment

You have a keyboard layout with "dead keys" (probably US-International) enabled. You can select the standard US keyboard layout in "Control Panel" under "Regional and Language".

share|improve this answer
    
Thank you, didn't expect the dead keys may apply to apostrophes on US international keyboard (despite the fact that I am used to these from my local keyboard which has accents) –  Marek Jul 17 '10 at 13:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.