Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed Google Chrome as my default browser in Ubuntu, and recently installed Gnome Do and enabled the Google Search plugin. The Google Search from Gnome Do works exactly as expected but for one thing: Chrome (which is typically set to open in "incognito" mode) does not open in "incognito" mode. The shortcuts on my desktop, taskbar, and menus all have the --incognito flag attached (which works just fine), but the browser refuses to open in this mode when launched from Gnome Do. Any suggestions?

Also, please note the settings for the Google Search plugin in Gnome Do:

alt text

It's obvious that Gnome Do just passes the Google Search blindly to the default browser. In other words, there are no configurable settings specifically for Chrome. Any thoughts?

share|improve this question
    
UPDATE: I figured out a partial solution. If I already have an incognito window open, a Google Search from Gnome Do will open the search in a new tab of the incognito window. It isn't a perfect solution, but I'll take it if no one else comes up with a better idea! –  jrc03c Jul 17 '10 at 19:09
add comment

1 Answer

up vote 0 down vote accepted

Go to System -> Preferences -> Preferred Applications

The first tab, "Internet", includes "Web Browser". Choose "Custom" (the last item). You will then be able to type in the "Command:" text box. Put in

chromium-browser --incognito %s
share|improve this answer
    
Perfect! Worked like a charm! You, my friend, are a genius. –  jrc03c Jul 17 '10 at 21:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.