Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I get this error in Ubuntu Lucid (which I did not get in Karmic):

dlopen '/home/wesley/.doom3/base/gamex86.so' 
failed: libgcc_s.so.1: version `GCC_4.2.0' not found 
(required by /usr/lib/libstdc++.so.6)

I only assume its from gcc in Lucid being a higher version: gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3. I have build-essentials installed as well.

I tried to symlink the missing lib without success. Can anyone help me out to get this working?

share|improve this question
up vote 1 down vote accepted

That error message means that your file (gamex86.so) was linked against the GCC_4.2.0 version of libgcc_s.so.1, but the version of that shared lib you've got doesn't support that. I'd guess that there's a .deb for lucid that delivers the 4.2 runtime somehow, though I confess that's it's very surprising that the newer version is not backwards-compatible. The ubuntu gang may have made a mistake. Recompiling/linking may be your best option.

share|improve this answer
    
thanks for the idea to get the .deb, I found it here: packages.debian.org/lenny/gcc-4.2 – invert Jul 22 '10 at 18:41
    
Also needed dependency cpp-4.2, I'm not too sure how to link it to the older 4.2 version, can I do it without affect the rest of my system? – invert Jul 22 '10 at 19:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .