Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a remote Debian 5 machine on which I'm trying to extract a tar-file (Django 1.2.1, but that's unimportant). The first 1300 or so files extracts just fine (of about 2800 in total), after which errors like

tar: Django-1.2.1/tests/urls.py: Cannot open: No such file or directory

shows up for the rest of the files, finally ending up with a

tar: Error exit delayed from previous errors

I use the command

tar xzvf Django-1.2.1.tar.gz

I've also tried with sudo (but I'm extracting in my home directory, which I should obviusly have permissions to use without). I've tried gunzipping first (runs flawlessly) and then running tar xvf, but to no avail. I've fetched the file using wget:

wget http://www.djangoproject.com/download/1.2.1/tarball/

I've tried redownloading it several times.

A test as suggested here simply lists all files in the archive (notably with "james" as owner, which is not my username - but I suppose it's the username of the guy who created the archive - not sure if that is significant).

Finally, I should note that both extration methods works fine on my local Ubuntu installating and that there is plenty of free disk space on the remote box.

So, now I have sort of run out of good ideas :-) Suggestions are very welcome.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

have you checked that you have enough space on the remote machine, maybe your disk is accidentally filling up

share|improve this answer
    
Yep. There are several gigabytes free. –  XerXes Jul 19 '10 at 15:20
1  
Nevermind, I was wrong, apparently. Even though the df command claims there is gigabytes of free space on the /home partition, I can't even create a new folder because of lack of disk space. After moving the tarball elsewhere, I can extract it. Thanks for making me check more thoroughly :-) –  XerXes Jul 19 '10 at 15:27
    
yea, you could have been hitting a user quota limit, or been on another partition and not realized it –  Roy Rico Jul 19 '10 at 17:49
1  
Perhaps you hit the inode limit on that partition. See what df -i tells you. –  Janne Pikkarainen Jul 29 '10 at 15:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.