Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to get a Ruby on Rails app hosted free somewhere, and Heroku is looking like my last resource. It is supposed to work on Linux, and the gem installs with no errors, but whenever I run any Heroku command it spits out several errors, all connected, and talking about a failed require. I looked it up in the code, and it says:

require 'readline'  

That is it.

I have tried to install every variation of libreadline that I can find and think of, but none of it makes any difference.

share|improve this question
add comment

2 Answers

Your question is a bit unclear. However what you can try:

  1. Make sure, that libncurses5-dev is installed on your system.
  2. Look up the directory, where Ruby is installed. Then change to subdirectory ext/readline
  3. ruby extconf.rb will generate a Makefile
  4. make && make install
  5. Try your Heroku command again.
share|improve this answer
    
The problem was that the ext/readline directory was non existent. –  Sir Emeth Jul 21 '10 at 6:22
add comment

I got it to work, but it was rather a hack. I hunted down the readline.so file from where it was installed (in some strange spot) and did a hard link to where ruby was looking for readline, and it worked. Not optimum, and I will definitely try what you guys recommend next time. Thanks

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.