Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My issue is with my external hard drive, which was doing fine until not so long ago. It stores 200 GB, and is a good old 3,5" (I took it from my previous desktop, and put it into an external case that has a USB interface).

This hard drive has 2 partitions, and in December, I thought I'd rename one of the partitions (without changing anything else). I then moved some files around from one partition to the other, and at some point the partition I had renamed went rogue: Windows cannot access it anymore.

The other partition is fine, all files are in place and can be accessed normally. The first partition exists: Windows can see it's there, but not recognize its name, nor access any content. I tried a tool that looked into the file structure of the partition and recognized that the folders were there, so I assume that those file are still there, but Windows can't get there.

My hunch is that something happened to the "name" of the partition, and now Windows can't access the rest of the files.

Is there a tool I can use to "rebuild" the 'heading' of the partition? If possible, I'd rather not lose the contents of that partition by reformatting it.

In summary, I need a hard drive partition tool or something like that that could fix whatever went wrong with the partition.

Thanks in advance for the advice.

share|improve this question
1  
You sure you don't mean 200 GB? –  TheLQ Jul 19 '10 at 17:23
    
Good catch Lord.Quackstar –  Vahid Jul 20 '10 at 14:38

3 Answers 3

If you can see the partition then I assume you can rename the partition like you did before. Try renaming it to something you know Windows can access.

If that doesn't work then you may have some corrupted sectors in the partition table. There are recovery programs which can deal with this but they are generally expensive. The "easiest" option may be to download a Linux live CD (a version of linux which runs directly off the CD) in hopes of being able to access the drive using some recovery tools.

The Cent OS live cd has some recovery features http://www.livecdlist.com/centos

share|improve this answer
    
Thanks for the quick reply! Windows won't let me remane the partition apparently: i tried renaming it just like i would usually through clicking the icon once in the Windows Explorer and right clicking for properties, but that just doesn't work. –  Vahid Jul 19 '10 at 17:57
    
Do you get an error message, is it greyed out, what lets you know that you can't rename it? –  Daisetsu Jul 19 '10 at 18:13
    
I'll check when at home and will get back. Thanks again for being so helpful. –  Vahid Jul 19 '10 at 21:23

In disk management, right click on the partition and choose properties, on the general tab at the top, see if you can rename it there.

share|improve this answer
    
Thanks, will try that and report. –  Vahid Jul 20 '10 at 14:39
    
Didn't work: "the name of the volume is not valid" It won't let me rename the partition. It also reads the partition as 0 bytes total size and 0 available. –  Vahid Jul 25 '10 at 22:32

I've had good experiences with TestDisk. Requires some simple knowledge of partitioning, but otherwise quite easy to use. It is a console app, but it provides it's own GUI-ish interface.

share|improve this answer
    
Thanks, i've hard a hard time finding freeware that could help me with this issue. –  Vahid Jul 20 '10 at 14:40
    
ok, i tried TestDisk,it does recognize the partition correctly, incuding its name and size. It started running a test on the cilinders, but got stuck at 21%. Should i deduce there's a defect in the partition? I had to kill the process manually. –  Vahid Jul 25 '10 at 23:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.