Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm getting pretty sick of how WinSCP screws up line breaks.

this is line 1
this is line 2

Gets turned into

this is line 1

this is line 2

I could just use FileZilla for FTP and Putty for SCP (I think putty can handle that) but, that's rather annoying. How can I mitigate this problem?

share|improve this question
1  
You can go into settings and have it use binary instead of automatic. Also if your using an external editor (like i am) be sure it doesnt mess around with it either. Mine has never given me a problem (i use programmers notepad aka pnotepad) –  acidzombie24 Dec 30 '10 at 5:34

2 Answers 2

I'd say that the comment left by acidzombie24 is the best advice. Personally I haven't come across a better FTP program than WinSCP. I recommend you change your settings to transfer using Binary, and use an editor like NP++ rather than the in-house editor.

Here are a few screenshots:

Binary Transfer

Editor

share|improve this answer
    
Adding to Merlin's answer, I fixed this by changing the Transfer preferences from Binary to Automatic. –  desbest Sep 14 '13 at 17:57
    
additionally you need to ensure that "text" mode is not forced on your external editor. Go to Editors, click your editor, click edit... then ensure "Force text transfer mode" is unchecked –  Vigrond Jun 21 at 23:16

My Only SOLUTION:

1) Open file (For example, i use Notepad++ )

2) Open "Find and Replace" window (check "Extended" under "Search Mode"),then type \r\n in first line, and \n in the second and click "Replace all" and Save.

From now, they should be opened normally.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.