Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I type in the wrong password at login, then the system forces me to wait for about a second before I can retry. Is there a way to reduce this timeout? Also, is there a global timeout setting for su and sudo or do I have to change those timeouts using a different method?

share|improve this question
    
For sudo-timeout see this question: superuser.com/questions/149731/… –  Bobby Jul 20 '10 at 12:37
add comment

3 Answers

up vote 2 down vote accepted

change the FAIL_DELAY line in /etc/login.defs. That should affect both login and su. But why would you want to do that ?

share|improve this answer
add comment

Checking out /etc/login.defs on Ubuntu 11.10 I see that the config option that b0fh mentions has been moved to the /etc/pam.d/login file as:

auth       optional   pam_faildelay.so  delay=3000000

which I changed from 3 sec. to half a second in order to lessen the effect of my bad habit of often getting my password wrong on the first go. (I consider the added risk of a brute-force attack taking one-sixth of the time it would have taken otherwise is a negligible factor)

share|improve this answer
1  
Oh my goodness, thank you. Incorrect passwords, while unoften, drive me crazy. –  shurane Dec 13 '12 at 20:18
3  
@shurane: I might be mistaken but IIRC I felt like changing this value actually didn´t make any difference in my system at the time. Could you confirm that my advice did change your timeout length? –  GummiV Dec 14 '12 at 7:45
2  
@GumminV: it does not have any effect for me on Ubuntu 12.10 –  sup Dec 14 '12 at 15:22
add comment

For some reason editing the delay in /etc/pam.d/login has no effect for my Ubuntu 12.04.

It would be best to have a small but nonzero delay (like half a second); I could not do that, but I was able to disable the delay by editing /etc/pam.d/common-auth from

auth    [success=1 default=ignore]      pam_unix.so nullok_secure

to

auth    [success=1 default=ignore]      pam_unix.so nullok_secure nodelay

No reboot required.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.