Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just run into an issue on Windows 7 whereby a couple of my desktop icons are not showing correctly, see screenshot:

enter image description here

I've tried deleting the icon cache and also changing the Max Cached Icons setting in the registry and rebooting, but neither have helped.

If I browse to C:\eclipse where my Eclipse icon links to, the eclipse.exe file in there also is not showing the expected icon.

I'm completely out of ideas. Can anyone suggest anything else I can try please?

share|improve this question
    
Do you see the correct icons if you reduce screen color depth (e.g. 16bit)? See sevenforums.com/tutorials/… Section 5 –  Andreas Jul 20 '10 at 7:21
    
Yes - I had tried that and they were visible but disappeared again when I reverted to 32bit. However, I just tried this again, kept the 16bit setting while I deleted the IconCache.db file in %USERPROFILE%\AppData\Local\, and then when I came back to 32bit they're all good again. Thanks for your help! –  am2605 Jul 20 '10 at 10:22

6 Answers 6

This was fixed by reducing screen color depth to 16bit as suggested by Andreas above, and then deleting USERPROFILE%\AppData\Local\IconCache.db. After restoring to 32-bit, the icons reappeared.

share|improve this answer
    
@Andreas: You should post an answer. @am2605: You should accept Andreas's answer. Keep it orderly, please. –  harrymc Jul 20 '10 at 11:00
    
@harrymc: I can't accept @Andrea's until he posts an answer can i? (it's only a comment at this stage). If Andreas posts an answer I will accept it and delete my own. –  am2605 Jul 22 '10 at 5:57
    
Helped me as well, thanks! –  Laimoncijus Dec 26 '12 at 8:34

Here's how to rebuild the icon cache:

  1. Delete the file %USERPROFILE%\AppData\Local\Iconcache.db
  2. Start Task Manager (Right click the taskbar, select Start Task Manager )
  3. From the Processes tab, select explorer.exe and click the End Process button
  4. Explorer (Taskbar, desktop etc) should now go away and come back.

How do I delete the file? In the Start menu, type in del %USERPROFILE%\AppData\Local\Iconcache.db I recommend copy/paste so you don't mistype it.

Why kill it rather than just logging off and on again?
Windows Explorer will load the icon cache into memory when it starts, and then update it in-memory. When it shuts down, for example when you log out, it will write that cache to the file listed above, making it saved as corrupted. By forcibly killing it, you prevent it from writing the (corrupted) cache to disk, and force it to build a new cache when it starts back up. Hopefully that cache will not be corrupted.

share|improve this answer
    
This helped to fix my problem, thank you very much! In my case, the icons of several system tools were gone, like Explorer itself, but also Notepad, Command Prompt etc. –  Martin Klinke Mar 12 at 8:04

we just had the corrupted icon issue on our Win7 system. The problem was that some apps and files had incorrect icons associated with them. We used the method above of adjusting color depth to 16-bit, but instead of manually editing the registry, we just logged-off after changing to 16-bit. That, as noted, forces Windows to save the new settings, overwriting the bad 32-bit iconcache. Log in, change back to 32-bit color, everything is fine.

share|improve this answer

My issue was with blank Chrome shortcuts. I tried changing my default browser to IE in "Default Programs" control panel and IE's icons work. This is apparently part of an operating system bug that is unresolved. I tried uninstalling / reinstalling, resetting thumbnail.db and overriding file associations via the control panels, changing screen resolution, nothing worked. I Finally Googled "File association" thinking I might be able to hack a solution via the registry and found a Blog that talks about various possible solutions:

http://www.winvistaclub.com/t19.html

The last solution talks of a utility called "Types" that lets you assign file associations in an alternative fashion. I scrolled to the .url file extension and double clicked the file extension. (The program interface isn't very intuitive). This opens a 4 tabbed window, select the "Icon" tab and browse to Chrome.exe (at the bottom of this window there is a folder icon next to a text field that lets you navigate to your app folder): %YourUserNameDir/AppData/Local/Google/Chrome/Application/ select chrome.exe

This will give you access to all of Chrome's icons, select the one you like and close the window, go see your desktop! I really like the big "g" icon it's nicer than the default Chrome logo.

I hope this helps!

share|improve this answer

None of these things helped me restore the Chrome icon but, as I was looking at Task Manager, I noticed that Chrome was labelled as old_chrome.exe (not sure when this happened). After following the workaround here: What happened to my Google Chrome Install (browse to the Google Chrome folder...delete the old version folder, along with the old_chrome.exe file. Then renaming the new_chrome.exe file back to just chrome.exe) my Chrome icon was restored.

share|improve this answer

Windows 7 64 bit, problems displaying some icons in desktop. Resolve: Changing to 16 bit and correct the problems. TY.

Eva

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.