Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i use linux ubuntu..i try to copy db and type some mysqldump command.. but at terminal show:

The program 'mysqldump' can be found in the following packages:
 * mysql-client-5.0
 * mysql-client-5.1
Try: sudo apt-get install <selected package>
bash: mysqldump: command not found

how to get mysqldump for my pc? i've tried to follow the instruction,but show like below:

Err http://ubuntu-ashisuto.ubuntulinux.jp jaunty/main libnet-daemon-perl 0.43-1
  Could not connect to ubuntu-ashisuto.ubuntulinux.jp:80 (122.216.218.146), connection timed out
share|improve this question

3 Answers 3

up vote 5 down vote accepted

How about ... doing what was printed on the terminal?

% sudo apt-get install mysql-client-5.1

or

% sudo apt-get install mysql-client-5.0

(pick the right version based on whats installed on your machine)

share|improve this answer
    
i've been try to do that but show connection time out. –  klox Jul 20 '10 at 7:56

Install the mysql client package.

In a terminal try the command sudo apt-get install mysql-client-5.1

(I would have thought that the message you got was clear enough, really.)

share|improve this answer
    
i've tried it but show error –  klox Jul 20 '10 at 7:59

Looks like you need to change the mirror ( repository) . Follow the steps mentioned in this tutorial. After changing it , you can use the commands mentioned by @Akira

share|improve this answer
    
show "No suitable download server was found". –  klox Jul 20 '10 at 8:59
    
check your source file which is located at /etc/apt/sources.list and follow this tutorial, if you dont find any mirror under that file. help.ubuntu.com/community/… –  ukanth Jul 20 '10 at 10:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.