Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Wampserver installed on Vista Enterprise and it works fine when I am logged in from my place of work (domain login). But when I run wampserver at home and try testing port 80 (with a script available as part of wampserver), it shows that port 80 is not in use. Windows task Manager shows that httpd.exe is running. But I am unable to access localhost or the local ip (127.0.0.1) from the browser. I have tried adding httpd.exe through the firewall on port 80 for the home / public profile etc. I even edited host file to map localhost to the local ip and commented out the ipv6 entry. But no luck so far. Any suggestions on what could be wrong?

share|improve this question

2 Answers 2

Ok. I figured this out. Seems that in httpd.conf, it was just listening on 80 - without an IP. In other words, Apache was "glomming onto all bound IP addresses" - Added the local IP and voila, it shows up.

share|improve this answer

Do you have Skype? Skype uses port 80 by default. If you do have Skype, go to:

Tools -> Options -> Advanced -> Connection -> Uncheck use port 80 and 443 as alternatives for incoming connections.

If you don't have Skype it could also be that port 80 is being used by some other application. Check what processes are being run on port 80.

share|improve this answer
    
No I don't have skype installed. I checked netstat -a and it shows Local Address 0.0.0.0:80. Not sure what that means. –  scronline Jul 20 '10 at 14:03
    
can you shut down the server and then check your ports again? –  rzlines Jul 20 '10 at 14:52
    
something absolutely offtopic but can you try XAMPP apachefriends.org/en/xampp.html instead of wampserver and check if that works out for you? –  rzlines Jul 20 '10 at 15:06
    
I shut down the server and it does not show Local Address 0.0.0.0:80. The thing is I can see both httpd.exe and mysqld.exe running in the Windows Task Manager, but I am not able to resolve localhost. –  scronline Jul 20 '10 at 17:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.