Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been administering linux systems for years now, but usually they are commodity boxes and as a result I rarely have driver problems, short of needing to install some "restricted" or "proprietary" driver package, or manually installing the nvidia binary drivers back in the day.

However, one question to which I have never picked up a straight answer regards common troubleshooting practice. Will lsusb and lspci list device for which a system has no drivers (kernel modules)? I am trying to install a webcam on a SiS-chipset laptop and though I can see a physical webcam, neither lsusb or lspci are showing me that any webcam-like device exists. What I want to know is if it would show anything, or if it needs drivers in order to show a device?

Cheers!

share|improve this question

4 Answers 4

up vote 5 down vote accepted

lsusb and lspci scan the buses at a low level, and do not require drivers in order for the devices to be found beyond those for the buses themselves.

share|improve this answer
    
that's the assumption I have operated on but thank you for the answer! –  Jonathan Jul 20 '10 at 14:43

Try "lshw" as superuser. It gives a detailed list of all hardware, your camera and details about it should be listed in there.

share|improve this answer

Try update-pciids and update-usbids(?) to update the local database of lspci/lsusb. Maybe the description of the webcam device is a very generic in the output of lsusb?

share|improve this answer
    
I ended up monitoring dmesg with the watch command, and then started holding down the function key and hitting random buttons. Sure enough, one of them powered on the missing webcam and it popped up in dmesg. now i just need to figure out why it's not creating a /dev/video node... –  Jonathan Jul 22 '10 at 3:27

As Ignacio says, lsusb and lspci do not need drivers - if something is connected they will show it, though they may only show a few numbers without any descriptive text if the connected device is not recognised - that is if the id number of the connected device is not in the database of values.

If there is not even an unlabelled device in the output, then it is likely your webcam is dead, or possible the USB port is dead. I would try the webcam in another computer, and try another device in the USB port. Does the webcam have any switch on it?

Also note that lspci will show USB controllers on the PCI bus, but it will not list any devices connected to those controllers, only lsusb will show that.

share|improve this answer
    
it's hard to think the webcam is dead, as it is integrated and the computer is brand new! –  Jonathan Jul 20 '10 at 14:43
    
I wonder if this means it is not turned on somehow, much like the wlan device not being detected until its switched on using the fn key sequence. –  Jonathan Jul 20 '10 at 14:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.