Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Many years ago I had my Thunderbird mail client set up so that when I pressed J it marked the mail as junk and moved it to the junk folder.

Now it just marks it as junk and I have to then later highlight all the junk mails, right click, and select "Move to junk again".

I have Thunderbird 2.0.0.22 and have my Junk settings set thusly:

alt text

What else do I have to do to get my mails I mark as junk to get automatically moved to the Junk folder?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Tools > Options > Privacy > Junk

Then make sure you check and select the following:

When I mark messages as junk > Move them to the account's "Junk" folder

share|improve this answer
1  
thanks, that was it, crazy I couldn't find it, sometimes thunderbird's settings seem like quite a labyrinth, another good checkmark on that panel is "Mark messages determined to be junk as read" –  Edward Tanguay Aug 1 '09 at 19:24
    
Feeling that pain of having to remember to check the settings in both Options and Account Settings. One dialog, keep it together Mozilla! –  random Aug 1 '09 at 23:23

Check whether you have that selected on all your accounts, AND the Junk Settings under Local Folders. I've found that strange things happen when one is selected but not the other. (It used to be the case that automatically marked junk don't get sent, but manually marked one does get sent to the junk folder for me.)

share|improve this answer
    
yeah local folders junk settings are same as above screenshot –  Edward Tanguay Jul 31 '09 at 20:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.