Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running 10.04 ubuntu, on a totally fresh, but update manager completed install. I've hit the recommended drivers from System > Administration > Hardware Drivers and let it run to install the 96 drivers.

I assume this version is best as I'm using a Geforce 128mb Ti4200 card.

It seems to be a fantastically popular problem, but I'm only getting 640x480 res. I've adjusted the panning to 1024x768, as the max res on my screen (NEC Multisync LCD1550V) and it's all okay, but I don't want to have to pan a 640x480 screen around!

I've tried pretty much all the fixes I can find. http://ubuntuforums.org/showthread.php?t=484680 https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

I've also tried the xrand --addmode S-video 1024x768 which just throws an unknown output s-video hmm. I've not had a go with the cvt as I'm not sure on all the stats I need for my screen.

I'm so close to closing out my install, with just this one little niggle remaining. I've tried a direct edit of the xorg.conf also, with adding a Modes "1024x768_60" line in the 'Screen' 'SubSection "Display"' to no avail. Restarting X by swapping to console 1 and executing /etc/init.d/gdm restart seems to just do nothing. I've also tried adding a metamode of 1024x768_60 @1024x768 to see if I can dupe the drivers, which didn't work either.

Hopefully I've put down enough info, it's 2am, and frankly I've had enough for tonight! Any help with this would pretty much guarantee you a spot in my all time hall of fame. Thanks, appreciated.

share|improve this question
    
Afterthought, I should mention that I've also tried gksudo displayconfig-gtk from Terminal with no success, and that the default 'Monitors' panel is reporting the panning, so a res of 1024x768. –  DavidYell Jul 21 '10 at 8:15

2 Answers 2

up vote 0 down vote accepted
+100

Try this: http://www.arunviswanathan.com/node/53

share|improve this answer
    
This looks very positive, will give it a try when I get home. –  DavidYell Jul 26 '10 at 12:45
    
I ended up here with similar effect, linuxjournal.com/content/… –  DavidYell Jul 26 '10 at 18:33
    
Turns out that I can use sudo nvidia-xconfig to set my xorg, then reboot, and ctrl+alt+[minus] to lower the res, and just edit out all the modes from the xorg that I didnt want, and it works perfectly! –  DavidYell Jul 27 '10 at 8:06

Does this article help (too long to reproduce here):
Ubuntu 9.10, Resolution Issues

Refresh rates and sync values also seem to be a common cause of such problems.
85Hz is apparently the correct refresh rate for your card.

share|improve this answer
    
Ah great, I didn't try running nvidia-settings as sudo from terminal, will give this a try! –  DavidYell Jul 26 '10 at 12:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.