Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I took a computer that was not updated for months. Internet was working just fine so basically, I updated zonealarm, avast and installed all windows updates and especially SP3. After that, when I reboot, Internet works fine but after few minutes, Firefox says that the connection was reset. IE does not work either. However, my connection is still up and running as I can make a ping on www.google.com for example. Here are the solutions I tried with no success so far:

1) Uninstalling SP3;

2) Uninstalling IE8 and IE7;

3) Manually setting DNS and IPs;

4) Removed proxy settings from Firefox and IE;

5) Restarting DNS and DHCP related services;

6) Reset TCP/IP with netsh int ip reset c:\resetlog.txt;

7) Updated my ehternet card driver;

8) Restarted, tweaked all the connections in any directions and any configuration possible I believe;

9) Disabled Zone Alarm and Avast;

Also, update kb981793 always fails on install.

Please, help me as I spent two days already on this and I cannot find any solution. If I cannot fix this problem tomorrow, I will have to format-reinstall everything.

Thanks for any help.

Regards.

share|improve this question
1  
Has the network card driver been updated? Sometimes, a new driver can be flaky and cause the machine to drop the network connection. – cole Jul 21 '10 at 14:41
    
Yes, see point 7. – Korchkidu Jul 21 '10 at 14:43
1  
I'd be willing to bet that the problem is with ZoneAlarm (ZA makes me sad :(). – squircle Jul 21 '10 at 17:40
    
Well, I disabled it and no difference... – Korchkidu Jul 21 '10 at 19:39
    
are you 100% sure there is no problem from ISP side? – tumchaaditya Jun 25 '12 at 6:20

I've seen this behaviour before on machines. Both cases it turned out to be ZoneAlarm. Not sure why those specific machines and not others. Very strange.

share|improve this answer
    
I completely disabled it. No change...;( – Korchkidu Jul 22 '10 at 12:22
3  
I had to remove it, disabling didn't help. It appears to stick something into the system that interferes, whether running or not. – Brian Knoblauch Jul 22 '10 at 13:44
    
No change... I finally reinstalledt everything. – Korchkidu Jul 23 '10 at 7:32

Just a shot in the dark, but, clear your DNS cache and use some alternate DNS server(e.g. 8.8.8.8 which is google's own DNS server)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .