Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Weird keyboard issue

Not strictly speaking a programming question but something that annoys me to no end while programming.

Win7 keeps waiting for a character to be typed after a ", ', ^ etc. How do I turn that off?

share|improve this question

migrated from stackoverflow.com Jul 21 '10 at 18:53

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Ignacio Vazquez-Abrams, Diago Nov 27 '10 at 5:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

2 Answers 2

Change your keyboard layout to something that doesn't have dead keys. Go to Control Panel, search for "keyboard Layout", and click "Change Keyboards or other input methods". When the Region and Language control panel appears, click "Change Keyboards...", and then click "Add" to add a new keyboard layout.

Since you didn't say what your existing keyboard layout is, I can't guide you further.

share|improve this answer
    
I'm pretty sure I tried that before... Lemme check... –  dascandy Jul 21 '10 at 18:18
add comment

this should be moved to superuser, but most likely your problem is that your keyboard layout is set to something funky. try setting it to English (United States) - US keyboard

share|improve this answer
    
Sorry, didn't know about superuser. I tried that, didn't fix it. Tried to find what else could be causing it. Eventually found what it appears to have been. Unlike previous versions it's not the keyboard setting (or it only works after a reboot), it's the system locale. Switched that to US and then it works. Back to programming! Thanks! –  dascandy Jul 21 '10 at 18:26
add comment