Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a laptop with a quadcore i7 that runs hot. I don't need 2 of the cores. How can I shut them off?

share|improve this question
Why? (15 chars) – Hello71 Jul 21 '10 at 20:28
What operating system ? – Paul R Jul 21 '10 at 20:29
With 2 fewer cores, I assume it will run cooler and the fans won't come on as often. It's Windows 7 x64. – mmm bacon Jul 21 '10 at 20:34
Maybe, maybe not. Either way, we need to know more about your laptop. What manufacturer/model is it? – squircle Jul 21 '10 at 20:37
It's an HP Envy 15 with an i7-720QM Quad Core processor (1.6GHz, 6MB L3 Cache) with Turbo Boost up to 2.8 GHz. ATI 5830 GPU. I would have bought the i5 model, but it's only sold with an i7 these days. – mmm bacon Jul 21 '10 at 20:53
up vote 0 down vote accepted

You can't command the processor to disable the cores, the only thing you can do to avoid the heat is going for another processor or to check that the processor is sufficiently cooled.

share|improve this answer

Many computers have BIOS options to disable cores. You can also disable hyper threading which is also disabling cores, though I doubt that would improve cooling much. A final thing that could be done is in Windows itself. Go to the Advanced Boot Options (msconfig > boot tab > Advanced options) and specify the number of cores you want to use. I would personally not recommend any of these solutions as it is basically castrating your machine. Find a better cooling solution or practice better usage of your machine such as using it only on hard surfaces, cleaning the dust out of the vents, using a cool pad, ect. You might also want to check for a BIOS update that will turn the fan on more often or use something like SpeedFan to manually control your fan speed and thus increase your cooling potential.

share|improve this answer
@TomWij I do not have that laptop (do you?) so I don't know what the BIOS options are. I see more and more new computers with options like this available in the BIOS, and there is nothing wrong with listing possible options for the OP. Please do not take it personal (I didn't down vote your answer) but you made a blanket statement, which was not entirely accurate, I simply pointed out the inaccuracy. As for the advanced options, if you disable cores how I said they will not register in the device manager, so my statement is true. I don't know what you mean about "only" affecting boot. – ubiquibacon Jan 22 '11 at 19:44
Ah, in that way, sorry... Well, it's located under the boot tab so it only effects the boot phase. During which Windows detects all cores and from that point they should all be used instead of a single one. @mmmbacon confirms this in his comment, but interesting enough: I don't know about the effect towards device manager, they shouldn't disappear but I haven't checked... – Tom Wijsman Jan 22 '11 at 21:14

The Intel i series tends to do this. They have a certain thermal limit built in and basically manage the system such that: if you are running on all cores, it manages speed among them and tries to run the system as fast as it can without overheating. If you aren't running all cores, it will shut down the cores that aren't used and try to overclock the cores that are used - up to the thermal limit. Note that it TRIES to overclock and this creates heat.

share|improve this answer
Right, but is there a way to manually disable 2 cores? Turbo mode on this system never seems to turn on. – mmm bacon Jul 21 '10 at 20:35
@mmmbacon: No, there is no way to disable them. Why would you spent a lot on a processor to downgrade the performance afterwards, I would rather fix the cooling instead. – Tom Wijsman Jan 22 '11 at 18:39

In Linux/Ubuntu, just run this:

sudo sh -c "echo '0' > /sys/devices/system/cpu/cpu1/online"

Replace cpu1 with cpu2 and so on to turn off more cores. And to turn them back on:

sudo sh -c "echo '1' > /sys/devices/system/cpu/cpu1/online"
share|improve this answer

Go to Run, type in msconfig, go to Boot tab, click Advanced Options, and select "Number of Processors". Then change it to half of the list (Pick 4, because you have 8 threads = 4 cores, so 4 threads = cores). Reboot ;)

share|improve this answer
Thanks. I tried that originally. Even though this kept Windows from using additional cores, I'm pretty sure the cores were still on and consumed power. – mmm bacon Nov 7 '10 at 15:16
Sadly, this only affects the boot phase... – Tom Wijsman Jan 22 '11 at 18:40

The myth about the 'boot' tab

This should stop Windows from scheduling threads on the cores, even if they are physically 'turned on'.

share|improve this answer
How does this solve the problem? – Simon Sheehan Nov 23 '11 at 3:26
link is broken. – Waldemar Wosiński Feb 7 at 12:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .