Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Just today Ubuntu Lucid (10.04) decided to not work. It just gets stuck in this screen:

screen shot

It looks like it's loading something but it's just stuck there. I can't login.

I've tried numerous solutions like: sudo dpkg-reconfigure xserver-xorg (nothing happens when I enter this command btw) but none of them works. I've also tried the recovery menu failsafeX option and it doesn't do anything either.

share|improve this question
    
What does the recovery console say? –  TheLQ Jul 22 '10 at 1:56
add comment

2 Answers

If disk is still active you may be in the middle of a disk check (fsck). I assume you let it run for a half hour or so before shutting it off...?

Try loading a live CD and see if that sticks too. If so think hardware failure. IF it boots ok then copy your data out to safe place before that goes away. Then poke around to your heart's content. And please check to see if anything out of the ordinary is listed in the boot messages. (dmesg) Once you've exhausted the "recovery" option you might just want to re-install. My experience with 5 currently active 10.4 installations is that they have been pretty stable so I would just try again.

Power failures or excessive heat are common reasons for this sort of abrupt work stoppage so you might want to think if either of those areas needs attention.

share|improve this answer
add comment

You should disable the ubuntu boot splash to take a look at the bootup messages. Maybe they can already tell you what's going wrong.

If that doesn't work, boot up a livecd and check the log files in /var/log (maybe dmesg will tell you more?) - Note: You have to mount the right partition first.

What does /var/log/Xorg.0.log say?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.