Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Firefox always asks me where to save a file. I set it that way and I want it that way.

However, it pops up an additional unnecessary dialog box asking me that to do with the file: 'You have chosen to open xyx.exe file' which is a binary file. Would you like to save this file?. The choices are 'Save' and 'Cancel'.

Only after showing this dialog box the browser allows me to enter WHERE to save the file.

How do I get rid of the first dialog and jump directly to the second one (where to save)?

share|improve this question
    
Well, I haven't found any current direct solutions. But the following worked on OS X with FireFox 7: I installed DownThemAll, restarted FF, attempted to download an EXE, then selected "Save File" and "Do this automatically from now on...", disabled then removed DownThemAll, restarted FF. Now "Binary Files" appears in the preferences and of course, begin downloading automatically. –  user100191 Oct 4 '11 at 17:20

7 Answers 7

There is a checkbox for "Do this automatically for files like this from now on." Selecting that checkbox will cause it to always go straight to saving the file.

do this automatically

share|improve this answer
    
My dialog box is as yours except that instead "What should Firefox do with this file?" I have "Would you like to save this file?" and after this message there is nothing. There is no "Do this automatically...". Like this: i.imgur.com/bBios.png –  Altar Oct 12 '10 at 12:37
    
It appears that option is only shown if there are multiple actions available. In this case, because I have the DownThemAll addon installed, it gives me the choice since it could either download it regularly or with DownThemAll. It appears that you can change this behavior manually in preferences though. On the Applications tab of the Options dialog, find "Binary file" and choose "save file" from the dropdown menu: grab.by/6PnU –  nhinkle Oct 12 '10 at 16:31
up vote 2 down vote accepted

Wherever I looked, there is no answer to this. Unfortunately, Firefox just don't allow you this customization.

share|improve this answer
    
Thanks for updating your question with what you found out. I think I may have found a solution which will actually work. If it doesn't, comment and we'll try to figure it out. –  nhinkle Oct 11 '10 at 20:39

Download a zip file, choose "save as" and choose "do this for file types like this in the future". Close firefox when download is complete. Open C:\Users\Username\AppData\Roaming\Mozilla\Firefox\Profiles\Profilename.default\mimeTypes.rdf using notepad. Replace all occurrences of zip with exe. Close the file and choose yes when prompted to save. Open firefox. Download a zip file, choose "save as" and choose "do this for file types like this in the future". Firefox will now download zip files and exe files without prompting. If you are nitpicky about the wordings used by firefox in the mime types section for exe files, then do another search in the mimeTypes.rdf file and replace the "Compressed (zipped) Folder" sentence with "Executable file".

share|improve this answer

Set browser.download.manager.alertOnEXEOpen to false in about:config. This fixed the constant EXE warning for me.

share|improve this answer

Firefox -> Preferences -> Applications

Gives you the options to change the actions taken for a given filetype. If you're getting that message, binaries are likely set to "Always Ask". Set it to "Save File" instead.

share|improve this answer

Indeed, the DownThemAll workaround doesn't work for me either.

I created bug #750228 on BugZilla. Feel free to add yourself to the CC list / vote on the bug / add context to the bug, but please refrain from adding "me too!" comments, maintainers don't like them very much.

Note: I'd have liked to add this post as a comment on Altar's post, but I don't have the rights for that. If somebody can convert my question to a comment on his answer, please do so.

share|improve this answer

I realize this is an old question but...

You might be able to manually edit MimeType.rdf in your profile directory:

http://kb.mozillazine.org/MimeTypes.rdf

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.