Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just got a 20MBit cable connection at home and tried to measure the bandwidth from this with my laptop. After a few tries (5), I could see I was getting 14/1 Mbps (down/up) speeds from speedtest.net

That was faster than my old 12Mbit connection (which measured 11.5/1) so I knew my provider did upgrade my connection, but I wasn't able to get all the speed I thought I would have. So instead of using the wireless connection, I tried using a regular ethernet cable and measure it again. It measured 19.5/1 which I believe is pretty close to the speed I was looking for.

The wireless router I'm using is a WNR2000 (version 1) from NetGear and a Intel WiFi Link 5100 from a VAIO Z520 (which has a gigabit ethernet lan port too).

I don't really know what else to do: router firmware is up to date, as is my wireless card driver. Windows says the connection is at 54Mbps, with all the bars for signal strength. The router is about 45 centimeters away from the notebook, so I don't think it is a signal strength problem.

Does anyone know what else I can try to get the best speed from my wifi?

TIA

share|improve this question
    
Don't forget that wireless devices can be too close to the router, causing signal issues. What happens from a farther distance? –  squircle Jul 22 '10 at 3:49
    
Hi thepurplepixel, could add an answer with your comment? I will check that out, and if it is the case, I will mark your answer as correct! Thanks! –  wtaniguchi Jul 22 '10 at 14:37

2 Answers 2

First of all it's really hard get the 20mbit/s, it'll always be around 16-18mbit/s (also check that in speedtest.net you choose megabits as preference to meassure speed) because of the latency or saturation of the network.

If you live in a place with a lot of wireless routers around it may cause some interference with the channels (here's a guide on how to optimize that). Also you may want to limit your data transfer mode to g-only so your router/computer stop transfer in b band that can slow things down a little bit.

Other things you can do: change DNS to either OpenDNS or Google Public DNS, if your router/computer has the option of afterburner turn it on, limit the data transfer to 54mbps only, and open ports for specific applications like torrent clients or things like that from your router.

share|improve this answer
    
Hi, thanks for the comments, but I pretty much thought about that too: I tried using one of the wired LAN ports in the router, and I got 19.5/1 in speedtest.net. I used viStumbler to check other wireless networks in the neighborhood, and most of them are using channels 1 and 6, and I put mine on 11 to avoid inteferences. Still no good. And about the DNS: I tried using Google's and my ISP's in all possible combinations, still no good. I will try to set the transfer to 802.11g only, and will update this question as soon as possible! Thanks! –  wtaniguchi Jul 22 '10 at 14:36
up vote 1 down vote accepted

I'm answering my own question because I made it work, but didn't use any of the suggested ideas in the other questions.

What I did was to change my data encryption to WPA2-PSK because apparently even 802.11n networks cannot go over 54 Mbps if using WEP or WPA. I thought I was damned, because I have another client that cannot use WPA2, but WNR2000 has a hybrid mode to allow both WPA-TKIP and WPA2-PSK modes at the same time.

Another thing I had to do is to enabled Wi-Fi Multimedia (WMM) in both my router (it was already enabled) and in my wireless adapter (it was disabled...). Another thing that the 802.11n spec requires to enable high throughput (i.e.: over 54 Mbps) is that devices should support 802.11e, which is a superset of WMM.

And that's it! I'm getting decent speeds now (19.3/0.97)!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.