Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running windows7 i have a shortcut to an FTP site. When you make this shortcut and point it to a location like ftp://127.0.0.1/ it automatically defaults to opening in Internet Explorer. This is not ideal.

I would like to have a shortcut that opens directly to Windows Explorer, as this is infinitely more useful for my purposes.

share|improve this question
    
If you do find yourself in IE viewing an FTP site you can always transfer to viewing it in Windows Explorer by pressing ALT+V, O to "Open FTP Site in File Explorer" –  Matthew Lock Oct 4 '13 at 7:09

5 Answers 5

up vote 10 down vote accepted
  1. Open Windows Explorer
  2. Right-click on "My Computer" in the navigation panel on the left
  3. Choose "Add new network location"
  4. Use the wizard to create a new network location for your FTP site
  5. The FTP site will now show up in My Computer as a network location. You can make shortcuts from there by right-clicking on the connection and choosing "send to" > "desktop (as shortcut)".
share|improve this answer
    
Works perfectly, thanks. –  James Jul 26 '10 at 12:27
    
it still opens in IE instead of explorer –  Felipe Sabino Dec 7 '12 at 13:39
    
@FelipeSabino please check the checkbox status for "Enable ftp folder view (Outside of Internet Explorer). Without this checkbox, the FTP URL is opened in the default web browser (Firefox in my case). Very confusing. –  MattBianco Nov 20 at 9:37

Create a shortcut with the path set to:

%windir%\explorer.exe ftp://<server address>/

And Scroll down to the Browsing section in the Advanced settings tab in Internet Options in Internet Explorer and make sure the box that reads "Enable ftp folder view (Outside of Internet Explorer)" is checked.

If this checkbox is not checked, Explorer starts your default web browser with the supplied URL.

share|improve this answer
    
But see @Gavin-Hudson 's answer also. –  Matthew Wilcoxson Jul 18 '13 at 13:32

The solution offered by nhinkle is good, but it might be only half of the solution. Follow his steps first. Once you have the ftp folder under My Computer, if you click the ftp network location and it still opens in IE, take the following steps:

  • Open Internet Explorer
  • Go to Tools > Internet Options > Advanced
  • Scroll down to Browsing and make sure the box that reads "Enable ftp folder view (Outside of Internet Explorer)" is checked.
  • Go back to the ftp folder you created by following nhinkle's steps. Double click it and log in to the ftp folder on you computer, NOT on IE.

This is true for IE8. I don't know if it's true for other versions.

share|improve this answer
    
This is true today (2014-11-20) as well. Make a shortcut like in the answer by @cloe or @nhinkle, and then check the check box in this answer. If it is not checked, the default web browser is launched. So the check box seems to have nothing to do with Internet Explorer. It instead affects the behavior of explorer.exe. Oh what a nice mess. –  MattBianco Nov 20 at 9:41
  1. Open a Windows Explorer window (win+e)
  2. Enter the ftp address into the address bar (add ftp:// if it's not already there)
  3. Provide any credentials to logon
  4. Drag the folder icon in the address bar onto the desktop to create a shortcut to the ftp site which will always open in Windows Explorer

enter image description here

share|improve this answer

The simplest way to control this kind of thing is to download the freeware FileTypesMan from Nirsoft. Make sure that the option to display URL protocols is enabled: on the menu, select Options > Show URL Protocols. Scroll down to FTP and click on it. Double-click the open entry in the lower pane and point it to Explorer instead of Internet Explorer. The only command line argument you should probably leave in is "%1".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.