Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I click a link from something like outlook or a program opens a web page (not when I click a link from within chrome). It opens up in Chrome since it is my default browser but if I already have a page open it will open in a new tab on that same window. I can't tell you how many times I forget about this and close the window out, accidentally losing the other tab too. Ofcourse, I can open a new chrome window and find it under recently closed tabs but I would really just prefer if they opened in their own window so I can prevent this.

share|improve this question

6 Answers 6

With a Macbook and Chrome browser, this extension works great for opening a new window and NOT opening a tab:

https://chrome.google.com/webstore/detail/new-tab-new-window/dndlcbaomdoggooaficldplkcmkfpgff

share|improve this answer
    
It took me 2 hours to find it but I love it. :-) –  graydog Sep 15 '13 at 14:16
    
duplicate of another prior answer –  Mark Schultheiss May 9 at 14:52

Mike Hardy posted a solution for Mac OS X. I'm using it in 10.7 Lion and it works fine.

The solution involves a small AppleScript application:

on open location theURL
    tell application "/Applications/Google Chrome.app"
        make new window
        activate
        set URL of active tab of first window to theURL
    end tell
end open location

Setting this application as your default browser will cause external program links to open in a new window in Chrome.

share|improve this answer

You can use the "New Tab, New Window" extension for this. They way it works is moving the newly created tab quickly to a new window. So there is a bit of redrawing, but it does work pretty well (for me at least).

Note, as @John mentions below, this extension makes the default behavior for all new tabs (even ones created from inside Chrome).

share|improve this answer
1  
this extension is not good... it always opens a new window, even when command-clicking from within chrome itself –  John Bachir Mar 15 '13 at 6:42
    
I actually think that is a good thing (I hate tabs :), but I agree given the question I needed to make that clearer in my answer. I've updated it. –  studgeek Apr 11 '13 at 20:40

Problem
For Linux, if you have multiple VNC servers, this same problem will occur.
That is,

$ google-chrome
Created new window in existing browser session

And no google chrome window will appear in the current X VNC session (a new tab will appear in the X session with the first instance of google-chrome).

Solution
A simple workaround is to run

$ google-chrome "--user-data-dir=${HOME}/.google-chrome/session${DISPLAY}"

This sets a unique user directory based on the X VNC instance in use. The user directory will be created as needed. The new google-chrome process will display within the current X VNC session.

share|improve this answer
1  
This is one of the most important bodies of text on the internet. I salute you. –  Jonathan Feinberg Nov 22 '13 at 16:11

In case any Linux users are wondering the same thing, I did this by copying /usr/share/applications/chromium.desktop to ~/.local/share/applications and then editing it as follows:

--- /usr/share/applications/chromium.desktop    2012-08-10 17:02:01.000000000 +0100
+++ /home/sam/.local/share/applications/chromium.desktop    2012-08-23  10:33:21.987359591 +0100
@@ -128,7 +128,7 @@
 Comment[zh_CN]=访问互联网
 Comment[zh_HK]=連線到網際網路
 Comment[zh_TW]=連線到網際網路
-Exec=/usr/bin/chromium %U
+Exec=/usr/bin/chromium --new-window %U
 Terminal=false
 X-MultipleArgs=false
 Type=Application

If you're using the Debian chromium package, and you don't mind setting this as the default for all users on the system, you can instead edit /etc/chromium/default and add --new-window to the CHROMIUM_FLAGS variable.

share|improve this answer
    
Thanks -- I was so tired of being switched to another desktop when I click on the Chrome launcher! I'll just add that you can simply edit the properties for the launcher icon to add in the --new-window option, if you're just looking to change the behavior of the launcher icon. Why isn't the option is documented in the man page??? –  AmigoNico Jan 30 at 14:48

There doesn't appear to be a user-friendly option to change this inside Chrome (presumably because most people prefer the new tab).

However, you can change this manually by editing the command specified in your Windows registry used to open an http url.

To do this, open regedit and:

  1. Go to HKEY_CLASSES_ROOT\http\shell\open\command
  2. You should see one key, named (Default). Double click this to get an editing popup.
  3. At the end of the Value data: field you should see the text -- "%1". Change this to --new-window "%1".

That will instruct Windows to open all http links in a new window of Chrome instead of a new tab.

Presumably, the same general idea is true for Mac and Linux, but I don't know offhand where they store the command to open urls.

share|improve this answer
    
When I double click default the pop has a field called Value Data it is empty. Should I just add --new-window or --new-window "%1" Also I am using Win7 if it matters. –  JD Isaacks Jul 22 '10 at 14:39
    
I tested that on Windows XP, and that key is where the default browser command is stored. Not sure if Windows 7 is the same, or you just don't have a default browser selected. The whole value should look something like: "C:\Documents and Settings\yourusername\Local Settings\Application Data\Google\Chrome\Application\chrome.exe" --new-window "%1" –  Cerin Jul 22 '10 at 16:42
    
Note, if you search the registry for any other keys containing "chrome.exe", and find one with a value containing " -- %1", then adding my change should work. –  Cerin Jul 23 '10 at 13:42
    
Worked like a charm: start chrome.exe --new-window –  Oak Apr 26 '13 at 20:01
1  
Is there any good way to "prevent" Chrome from overriding these changes every update? (Which happens relatively frequently.) –  Qtax Aug 15 '13 at 11:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.