Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Global search in Thunderbird 3.1.1 on Mac OS X 10.6 does not work. It is enabled in the preferences.

I am searching on text that is in message bodies or subjects. I have also tried searching on email addresses. Thunderbird searches forever and never shows results. I have tried searching Mozilla knowledge base and forums, but have not found any solutions.

Any suggestions on how solve this, or at least some diagnostics I can do?

share|improve this question

1 Answer 1

I know that when I first installed TB3 I had to leave it "online" or else it wouldn't index.

This add on might help too: https://addons.mozilla.org/en-US/thunderbird/addon/9873/

share|improve this answer
    
TB3 has been online long enough on my system to have indexed everything. When I open the activity monitor while it is downloading I occasionally see it adding to the index. The add-on looks interesting. I am not sure how to inturprert it. When I search for word in a message that is on disk and has an ID I still do not get results. –  railmeat Jul 24 '10 at 5:38
    
I had similar problems to you, and the forums at TB3 were not much help, so all I can tell you is what worked for me... The add-on I pasted in can limit the accounts that are indexed. In my ase I had 4, and only wanted one indexed. Things started working after I did that AND deleted my global-messages-db.sqlite (the file that stores the indexes). How big is yours? –  NinjaCat Jul 24 '10 at 7:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.