Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm encountering this "funny" issue since I resized my partition, namely when I'm trying to hibernate my system, the screen will then go blank for about 10 seconds (which is fine) before the login page appears, i.e. it somehow refuses to hibernate and brings me back to the login page.

Any idea on why this is happening / how to troubleshoot this?

share|improve this question

3 Answers 3

up vote 0 down vote accepted

could be you corrupted some system files during the partition. first i would try:

  1. Open an elevated command prompt. To do this, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.
  2. Type the following command, and then press ENTER:

    sfc /scannow

The sfc /scannow command scans all protected system files and replaces incorrect versions with correct Microsoft versions.

share|improve this answer
    
Tried this and it reported that all file dependencies are in place (or something like that), but the problem still occur =/ –  andreas Jul 23 '10 at 2:06
    
The computer uses the Hiberfil.sys file to store a copy of the system memory on the hard disk when the hybrid sleep setting is turned on. If this file is not present, the computer cannot hibernate. Hibernation is made unavailable when you set the value of the Hibernate after setting to Never by using the Power Options item in Control Panel. To make hibernation unavailable, follow these steps: –  djshortbus Jul 23 '10 at 13:47
    
Click Start, and then type cmd in the Start Search box. In the search results list, right-click Command Prompt, and then click Run as Administrator. When you are prompted by User Account Control, click Continue. At the command prompt, type powercfg.exe /hibernate off, and then press ENTER. Type exit, and then press ENTER. –  djshortbus Jul 23 '10 at 13:48
    
To make hibernation available, follow these steps: Click Start, and then type cmd in the Start Search box. In the search results list, right-click Command Prompt, and then click Run as Administrator. When you are prompted by User Account Control, click Continue. At the command prompt, type powercfg.exe /hibernate on, and then press ENTER. Type exit, and then press ENTER to close the Command Prompt window. –  djshortbus Jul 23 '10 at 13:48
    
The hibernation button has been there since forever, the thing is, it can't hibernate (see my post) –  andreas Jul 25 '10 at 4:50

I've had this problem too and I solved it by updating my NVidia drivers. Sometimes drivers prevent the system from going in to sleep mode. I don't think the resizing of your partition has anything to do with it.

share|improve this answer
    
I'm using ATI and the driver's already updated, still the same problem. –  andreas Jul 23 '10 at 2:06

A common cause of hibernation issues is that some device isn't playing nice and wakes up your computer immediately. In particular, Logitech devices have been known to do this.

Open the device manager and check the properties of various devices, especially keyboards, mice and other external devices. Some of these will have a tab about power management. On that tab, you can select that the device isn't allowed to wake up the computer. If you prefer, you can try one device at a time to figure out which device is causing the issue, and then only disable that one.

share|improve this answer
    
Ok, I've disabled all devices capability to wake up the laptop, but still nil :( –  andreas Jul 23 '10 at 2:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.