Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to set up a svn server on my computer, so it's available from anywhere.

I think I set up the repository correctly, using CollabSVN. If I go to Repo-Browser with TortoiseSVN and point it to svn://localhost:3690, it shows the proper repository.

The problem now is that I'm behind a router. My local IP is 192.168.1.45. Doing svn://192.168.1.45:3690 also works. My global IP is, say, x.x.x.x. Just doing svn://x.x.x.x:3690 doesn't work, which makes sense, since I have to set up port forwarding.

I'm using a Verizon router. Using their web interface (on 192.168.1.1) I added the following port forwarding rule:

IP Address forward to: 192.168.1.45
Source Ports: Any
Dest Ports: 3690
Forward to: 3690
Protocol: TCP

However, even after applying this rule, going to svn://x.x.x.x:3690 doesn't work. It takes a few seconds to fail, then says that the connection couldn't be established because the server connected to didn't respond properly after a period of time. What's interesting is that a random port, like svn://x.x.x.x:36904 fails immediately, saying that the target machine actively refused the connection. So I figure that the forwarding rule did something, but not fully what was necessary.

Any ideas on how to get this working? The router model is MI424-WR and the firmware version is 4.0.16.1.56.0.10.12.3.

UPDATE: I also tried setting destination port to 45000, and still forwarding to 3690, in case something was wrong w/ the lower-numbered ports, but to no avail. I also tried port 80 to port 3690, still all in vain.

share|improve this question
    
Are you using the Westell 7500? – jer.salamon Jul 23 '10 at 14:55
    
not quite. i noticed the instructions on verizon's site, and although the interface looks similar, the port forwarding part was different – Claudiu Jul 23 '10 at 14:57
    
Well our company has about 50 locations that have DSL and we received the 7500 Verizon router. Since day 1 they had nothing but issues with port forwarding. We swapped them out for 6110 bridge only modems and Netgear routers because they had so many issues. – jer.salamon Jul 23 '10 at 15:01
    
hm it could just be router fail. i remember getting port 80 to forward properly, though.. i wonder why this one doesnt. – Claudiu Jul 23 '10 at 15:05
    
check this post (serverfault.com/questions/71775/…) – Fergus Jan 10 '11 at 23:57

Many routers don't support this, but if you try it from outside your internal network it will work.

Ask a friend to try that svn://x.x.x.x:3690 from somewhere else on the internet and see if it works, or if you have a shell account somewhere, ssh to there and try to svn ls svn://x.x.x.x:3690

I don't know the name for this firewall feature. I do know that making linux do it (which is what your wrt54gl uses) is a matter of adding an SNAT rule along with the DNAT rule.

There is a VERY good explanation here : http://security.maruhn.com/iptables-tutorial/x9305.html

share|improve this answer

Try forwarding on both TCP and UDP. Some quick research showed that SVN uses both.

share|improve this answer
    
i tried that earlier and it didn't work. i just re-added it, since it seems like i'll need it anyway, but the same problem occurs – Claudiu Jul 23 '10 at 15:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .