Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Why would disks mysteriously become write-protected?

I have a Raidon GR3630-2S-SB2+ External RAID enclosure that I've just hooked into my system. For some reason, it's coming up as write-protected.

The issue seems to have to do with my Windows setup, because I'm able to write to the drives when I plug the enclosure into another system running the same version of Windows (Windows 7 Enterprise x64).

For both of my machines I have administrative access, and "Full Control" is granted to Administrators in the Security tab of the drive properties.

Does anyone know how to enable write access to an external drive like this? Are there any other steps I could take to troubleshoot the problem? Or is there any other info that you would need?

Thanks in advance!

share|improve this question

migrated from serverfault.com Jul 23 '10 at 18:20

This question came from our site for professional system and network administrators.

marked as duplicate by Ivo Flipse Jul 24 '10 at 8:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Possible duplicate: superuser.com/questions/112401/… –  Hello71 Jul 23 '10 at 19:33
    
Possible duplicate: superuser.com/questions/148385/usb-write-protected –  Hello71 Jul 23 '10 at 19:34
    
Possible duplicate: superuser.com/questions/158083/… –  Hello71 Jul 23 '10 at 19:34
    
@Hello71, @IvoFlipse This isn't a duplicate of any of those. The drives and the storage device are functioning perfectly well and do not need to be wiped or replaced. The fix suggested by @BloodPhilia worked. Please do some research before flagging questions as duplicates. –  Jake Jul 31 '10 at 23:42

2 Answers 2

up vote 0 down vote accepted

Put this in a .bat file and execute it:

cd\
reg add "HKLM\System\CurrentControlSet\Control\StorageDevicePolicies" /t Reg_dword /v WriteProtect /f /d 0
share|improve this answer
    
this worked partially, but i need to do it for "ControlSet001" and "ControlSet002" as well. I found the problem described here: cybertechhelp.com/forums/showthread.php?t=185805 –  Jake Jul 31 '10 at 23:40

First thing to check is to see if you can write to any removable devices on the machine as there are group policy settings which can disable write access to these devices (which I don't have off hand).

Otherwise, you can check/set the readonly status using DISKPART (Try googling for DISKPART ATTR)

share|improve this answer
    
Thank you for the suggestion - it helped me diagnose the issue but ultimately I went with @BloodPhilia's approach. I'd vote you up if I could ;) –  Jake Jul 31 '10 at 23:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.