Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sometimes, for no apparent reason, Firefox goes to the previous page. This is often very annoying; for instance, if I was entering information in a web form, I lose all of it. I've been trying to detect a pattern to this but so far nothing.

EDIT1: When this happens, I'm usually not even typing or looking at the screen. I look down at my credit card or whatever, look up and bingo! previous page.

EDIT2: It just happened again! I was typing a comment on Superuser, paused for a few seconds while I pondered something, with none of my fingers anywhere near the backspace key, but holding down the left Shift key. While I stared at the screen, it went back to the previous screen. Maybe a keyboard problem?

EDIT3: And again. Exactly the same situation as last time, except that the cursor was in a superuser answer box, not a comment box. Not that Superuser has anything to do with the problem; it's just where I've been spending time lately!

EDIT4: And again, this time while I was typing in an edit box on my Geeklog blog, but again using Firefox.

EDIT5: It's definitely Firefox, and it's definitely from holding down the left Shift key for an extended period. Bizarre. You might be tempted to tell me not to hold down that Shift key, but I'm not even aware I'm doing it until I go back a page. If it wasn't for this problem, I likely never would have noticed at all.

EDIT6: I've added my observations to Firefox Bugzilla bug report #513218 which seems to be related.

EDIT7: This problem still happens in Firefox 4.

share|improve this question
3  
Do you have a 5 button mouse? The buttons near the thumb groove are typically forward and backwards, I had to disable them for this exact annoyance (they're very easy to hit). –  John T Jul 24 '10 at 16:56
    
@John T: Regular old-fashioned two-button plus mousewheel Microsoft mouse. Not one of those fancy new rigs. –  boot13 Jul 25 '10 at 4:37
    
does this happen in any other programs? have you tried another browser? If its limited to only firefox, then perhaps reinstall firefox and see if that works, otherwise, perhaps its some sort of malware/virus- so scan your computer. –  Nathaniel Saxe Aug 11 '10 at 15:01
    
@Nathaniel Saxe: I've been watching for this in other programs and so far haven't seen it. Like I said, Firefox has always had weird keyboard issues, so maybe this is yet another. I'll browse the Firefox Bugzilla to see if anyone else has reported it. –  boot13 Aug 11 '10 at 15:54
add comment

2 Answers

My guess is you are hitting backspace on accident. If you hit backspace while focused on the firefox window, it will go back a page. If you THINK you are in a web form but it didn't take focus, it'll go back.

share|improve this answer
2  
True of Google Chrome too. –  ChrisF Jul 24 '10 at 17:10
    
I thought of that. I actually use Backspace almost to the exclusion of all other methods for going back a page. I don't think I'm hitting it by accident, and if I pressed Backspace to remove a character in a text box and it went back a page, I'd notice. Also, Firefox has had keyboard issues forever, so that may be a factor. –  boot13 Jul 25 '10 at 4:35
    
Just for future Google hits: if it is related to the Backspace (and, on a Mac, also to key combinations like Cmd-Left), then see How can I disable the Backspace button's “Go Back” functionality in Firefox? –  Arjan Sep 18 '10 at 15:39
    
Is it possible you might also be hitting Alt-Left? Thats another shortcut for Go Back in nearly all web-browsers... –  camster342 May 26 '11 at 21:32
add comment
up vote 1 down vote accepted

I think I figured this out: my mouse's scroll wheel is very loose and sometimes scrolls a notch by itself if I leave it between notches. In Firefox, holding Shift and scrolling the mousewheel navigates forward and back in pages. I changed the Firefox setting mousewheel.withshiftkey.action from its default of 2 (navigate pages with Shift-scrollwheel) to 3 (zoom text with Shift-scrollwheel). Hopefully that will do it. I will post my observations. Also, once I'm satisfied that the problem is gone, I will rip apart my mouse and try to stiffen up the scrollwheel.

UPDATE: since I made the mousewheel.withshiftkey.action change, this problem has not recurred. This problem is resolved. Can I choose my own answer?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.