Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Linksys WRT110 wireless router. However, my friend was just over and said that my network was awfully slow. I'll try to get some numbers later tonight or tomorrow, but for now I'm interested in different options and configuration settings that I can use to improve performance, for not only myself but for people who come over my place to visit.

The only thing that I can't do is use Wireless-N only, as I don't have an N card in my laptop, which I might want to take wireless sometimes.

share|improve this question

migrated from serverfault.com Jul 25 '10 at 15:23

This question came from our site for system and network administrators.

5 Answers 5

Can you define "awfully slow"? In what sort of conditions? How man active clients?

The first thing I always check with a wireless AP, especially the 2.4GHz models, is channel contention. Grab something like netstumbler and take a look at what other APs are active in your area. If you other APs with strong signals are on or near your channel, that will really slow things down. You want to choose the center of the quietest section of the spectrum, remembering that 802.11b/g/n channels overlap.

share|improve this answer
    
Under Wireless > Basic Wireless Settings in the administration tools, both Wide Channel and Standard Channel are set to Auto and there doesn't appear to be a way to change this. I did grab netstumbler and found that there are a several wireless points on channels 1 and 6, so I now know to avoid those channels. –  Thomas Owens Aug 6 '09 at 0:01
    
And what channel is your AP using? I'm surprised that they don't allow you to manually set the channel. Perhaps in some sort of "advanced" menu? After managing a few quite large wireless networks (70+ APs) I have learned to distrust auto-selected channels... –  Insyte Aug 6 '09 at 0:11

Most consumer routers cannot handle multiple data rates simultaneously, and they drop to the lowest common denominator. As soon as an 802.11b device hops onto a wireless G or N network, the data rate will drop to wireless B speeds of 11 Mbps, with an actual throughput of maybe somewhere around 5 Mbps.

I'm afraid you might have to get a newer network adapter for your laptop. Fortunately, if you watch techbargains.com or slickdeals.net (or any other deal site of your choice), you can sometimes find a cheap USB wireless N adapter for $20 or less.

Or, if you don't have any money, just disable your laptop's wireless adapter when you have company, and plug directly into the router with an Ethernet cable. The transfer speeds should jump back to 802.11n if everyone else connected has wireless N adapters, or 802.11g (54Mbps) if everyone connected has at least wireless G.

share|improve this answer
    
At the time my friend said the speeds were slow, he was the only one on the wireless network. I was using ethernet to connect to my router, which is connected to my modem. –  Thomas Owens Aug 6 '09 at 0:16
    
Was your laptop's wireless adapter disabled? If so, you might want to check in the router's control panel and see if any of your neighbors were connected with slow network adapters. Or, just to be sure, it might be a good idea to try connecting your friend's computer via Ethernet, to make sure the problem isn't just a slow Internet connection. –  rob Aug 6 '09 at 0:23

Um...what was the definition of slow? I mean, there are people talking about channel contention, etc...but what if it was just the site your friend was visiting?

Are you testing this by seeing what your throughput is between two machines on the same network? It might not be your wireless at all. Kind of odd that your friend noticed this on his system but you haven't noticed anything unusual, no?

share|improve this answer
    
What he said ^ :) –  dimitri.p Aug 6 '09 at 1:28

This site has very effective and cheap ways to improve your wireless signal by directing it where it needs to go.

share|improve this answer

I take it that the direct ethernet connection isn't slow, or you would have noticed it already.

Slowness in a wireless network might be caused by interference, maybe by your neighbor's router. Try and change the router's channel to number 11, which is also the strongest, and check for an improvement.

Having an unbiased speed-test is important in such cases, such as using speedtest.net.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.