Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I bought my MBP Safari worked fine and it's default language was En but after I added Farsi as my second Language Safari now uses my Farsi setting and show all text in RTL (because in Farsi I write from right to left). How can I change Safari's default language back to English?

I read this but it's not a proper solution for me.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

There is a freeware, Language Switcher, to launch single applications with a different language.

To remove not needed languages of an application, there is Monolingual (.sf.net) and similar apps.

share|improve this answer
    
It's a nice application and work for me, thank you for your answer but I also need a solution that can easily can config in Os X without any extra application. –  Am1rr3zA Jul 25 '10 at 21:12
1  
You can drag the languages in System Preferences -> Language & Text -> Language in your desired order. OS X uses the first language, applications will be launched in the first available language. In general, check "Languages & Text" for appropriate settings. –  ischeriad Jul 25 '10 at 21:19
    
yep, :D this work it's a tricky solution tanx. –  Am1rr3zA Jul 26 '10 at 8:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.