Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows-7 desktop at office, to which i try to do a remote desktop connection from my home laptop, Windows-Vista home premium. When i say mstsc.exe, enter remote login and password, after some time, it gives an error saying:

Remote Desktop Disconnected: This computer cannot connect to the remote computer. Try contacting system administrator of the remote computer."

On the remote computer:

  • I have enabled the services needed for remote desktop connection, and they are started automatically.

  • I have enabled "Allow remote Access to the computer"

  • In windows firewall of remote computer, i have allowed Remote Desktop Connection service.

1] How can i fix this and get to do a remote desktop connection to my office computer? Any other settings in need to do on remote computer.

2] FYI - My office has a VPN network setup and i can connect to it. I have tried this remote desktop connection to my office desktop both:- after connecting to the VPN network, and also without connecting to the VPN network. In both cases it was same error and i could not connect.

3] Does VPN have any relation to Remote desktop connections being allowed/disallowed. Do they have relation?

Any pointers would help.

Thank you.

-AD.

share|improve this question
add comment

3 Answers

You almost certainly must use a VPN to connect to your work LAN.

Once you establish a VPN connection, if you do an IPCONFIG /ALL, does one of the lines contain an IP address similar to that of your work LAN? In otherwords, if you home LAN is 192.168.0.x, and your work LAN is 172.18.1.x, if you run IPCONFIG after running the VPN, do you have a 172.18.1.x address on your computer?

Once you have an address matching your computer, can you ping the work computer's IP address?

If you can ping the work computer's address, but still can't VPN, check with your network admin since it may be that RDP port is blocked to your computer on the corporate router.

share|improve this answer
    
When i establish a VPN connection, i see my ip address is similar to the office network after. But i cannot ping to the host i am trying to connect on remote desktop. ping times out. What could be the issue. Any pointers to fix it. –  goldenmean Jul 26 '10 at 21:25
add comment

You almost certainly have to contact your network administrator.

You almost certainly have to use the VPN, but that may not be sufficient if the computer is not routable from the VPN.

share|improve this answer
add comment
up vote 0 down vote accepted

The solution to the problem I asked, was'Not network related'. In fact a bit silly.

It turned out that my desktop computer was going into Sleep mode after 15 minutes. So whenever i tried to make a remote desktop connection or even ping it, the network interface was inactive because computer was in Sleep mode. I put it to "Sleep Never mode" setting and it worked just fine.

At times some problems might really have some simple solutions. It's just we obscure the simplicity by some complexity!

cheers,

-AD

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.