Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Mac OS X 10.6.3. I also have Windows 7 installed on the same machine.

The clock on Mac OS X keeps on gaining time. I have set the proper timezone both in windows as well in Mac OS X.

Any help in resolving this problem?

share|improve this question
    
What's your version of Bootcamp ? –  Pierre Jul 26 '10 at 10:26
add comment

2 Answers 2

This can help you :

I found a better solution to this whole thing. The problem with the Windows clock being off is because the hardware clock (the one on your actual motherboard) is being set to "Universal" time, or GMT, when you shut down your MacOS bootup. When you boot Windows, Windows assumes your clock is set to your local timezone because that's what Windows does by default. This explains why the people who set their MacOS clock to GMT got the right time in Windows... If the hardware clock is being set to "GMT," when it's actually the local time, Windows will pick this setting up as local time as it did before.

To fix this, you need to add a key to your Windows system registry to tell Windows that your hardware clock will always be GMT.

* WARNING: Editing your registry improperly can render your Windows installation inoperable. Proceed VERY carefully. I am not responsible if you mess something up. *

The short solution for people who know how to edit the registry: A DWORD key called HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\TimeZoneInformation\RealTimeIsUniversal needs to have the value of "1"

The step-by-step solution is as follows: 1. Boot Windows

  1. Click Start --> Run and type regedit. Click OK

  2. The Windows Registry Editor should pop up. Navigate within the explorer to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\TimeZoneInformation

  3. Click on the TimeZoneInformation "folder" from the navigation pane if you haven't already done so.

  4. This assumes the correct key doesn't exist. If it does, you will just change the existing key's value: Right click on the white space within the folder (If you don't have a right mouse button, you may need to download a program called applemouse to emulate the "control-click" of the apple 1-button mouse). Select new --> DWORD Value. Title the key "RealTimeIsUniversal" (No quotes). Set the value to "1" (No quotes again). Hexidecimal should be fine.

  5. Either reboot and set the clock in MacOS or set the clock in Windows. You should now be able to reboot into either OS and have a correct clock.

share|improve this answer
    
Just wanted to make it clear that the problem is in Mac OS X. Windows is showing properly. I am not clear why should I be tweaking windows settings when the problem is in OS X. Any suggestions? –  mark Jul 26 '10 at 11:33
    
This is not a situation where you can tell who is wronf and who is right. The fact is that the 2 OS's are stepping each other on their feet. –  Pierre Jul 26 '10 at 13:46
add comment

Do you have 'Set date and time automatically' checked (under Date & Time > Date & Time in Settings)? If so, your Windows install may not have the correct time.

share|improve this answer
    
Yes, it is checked. My win 7 install also has the correct time. –  mark Jul 26 '10 at 11:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.