Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Eee PC 904D that i use for development, because it's tiny and little, but i have a PC too. But in my Eee PC that i have Ubuntu Intrepid Ibex with the Netbook Remix(Easy Peasy), when i want to use the ethernet cable for the internet i connect it and tryes to connect, but in aproximatly 10 secs trying to connect it fails and change the icon like i don't put any cable, but the cable is connected and other computers when i try to use this cable connect normally, if is needed here is the content of /etc/dhcp3/dhclient.conf file:

# Configuration file for /sbin/dhclient, which is included in Debian's
#   dhcp3-client package.
#
# This is a sample configuration file for dhclient. See dhclient.conf's
#   man page for more information about the syntax of this file
#   and a more comprehensive list of the parameters understood by
#   dhclient.
#
# Normally, if the DHCP server provides reasonable information and does
#   not leave anything out (like the domain name, for example), then
#   few changes must be made to this file, if any.
#

send host-name "<hostname>";
#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "fugue.com home.vix.com";
#prepend domain-name-servers 127.0.0.1;
request subnet-mask, broadcast-address, time-offset, routers,
    domain-name, domain-name-servers, domain-search, host-name,
    netbios-name-servers, netbios-scope, interface-mtu;
#require subnet-mask, domain-name-servers;
#timeout 60;
#retry 60;
#reboot 10;
#select-timeout 5;
#initial-interval 2;
#script "/etc/dhcp3/dhclient-script";
#media "-link0 -link1 -link2", "link0 link1";
#reject 192.33.137.209;

#alias {
#  interface "eth0";
#  fixed-address 192.5.5.213;
#  option subnet-mask 255.255.255.255;
#}

#lease {
#  interface "eth0";
#  fixed-address 192.33.137.200;
#  medium "link0 link1";
#  option host-name "andare.swiftmedia.com";
#  option subnet-mask 255.255.255.0;
#  option broadcast-address 192.33.137.255;
#  option routers 192.33.137.250;
#  option domain-name-servers 127.0.0.1;
#  renew 2 2000/1/12 00:00:01;
#  rebind 2 2000/1/12 00:00:01;
#  expire 2 2000/1/12 00:00:01;
#}

Here is the ifconfig log:

ubuntu@ubuntu-laptop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:22:15:a2:6a:8f  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:220 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:30 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1880 (1.8 KB)  TX bytes:1880 (1.8 KB)

wlan0     Link encap:Ethernet  HWaddr 00:15:af:eb:d8:6e  
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::215:afff:feeb:d86e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5975 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6177 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3216735 (3.2 MB)  TX bytes:1377796 (1.3 MB)

wmaster0  Link encap:UNSPEC  HWaddr 00-15-AF-EB-D8-6E-38-36-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX
share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Have you tried network-manager? Network manager doesn't use dhclient.conf. You can find its configuration under /etc/NetworkManager but it's best done using the configuration dialogs.

share|improve this answer
    
I'm using the network-manager! –  Nathan Campos Aug 1 '09 at 23:25
add comment

Does it get an IP address? type "ifconfig" in a console and look for an address for eth0. If it gets an IP address, try to ping another machine by its IP.

share|improve this answer
    
Now i put the ifconfig log, but if i connect the same cable in my PC, it gets the ip and all ok, and in my notbook, in every place that i put a cable on it i have this error. –  Nathan Campos Aug 1 '09 at 18:07
    
Try this : connect the cable, then from a shell do "sudo /etc/init.d/networking restart" to reload your network configuration. That should work. –  wazoox Aug 2 '09 at 20:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.