Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an access database that I gave to a user (shame on my head). They were having trouble with some data being too long, so I suggested changing several text fields to memo fields. I tried this in my copy and it worked perfectly, but when the user tries it they get a "Record is too large" messagebox on saving the modified table design. Obviously the same record is not too large in my database, why would it be in theirs?

share|improve this question
1  
Are you and the user both using the same version of Access? Are you entering the EXACT same data into the field that they are? –  JNK Jul 27 '10 at 12:29
    
@JNK Yes, same version. It's not when putting the data in that the problem occurs, but when changing the table design. –  C. Ross Jul 27 '10 at 14:44

2 Answers 2

This question is fairly old but I just experienced this problem today and found a solution that may help others in the future.

The only thing I could do was to clear out all of the old records in the table before making a change to the table design. Even though none of the records seemed to be 'too large' they were preventing any updates to the table design.

Then only after saving the changes to the table will you be able to paste in the old information. When pasting the information back into the table you might get some errors on specific rows or fields that will help you narrow down the problem.

share|improve this answer

I've experienced this problem today, and have spent the majority of the day dealing with it!

The issue was that I was dealing with and old database schema, produced in the Lotus Approach 97' days. I migrated this a while ago now, and had not experienced such a problem.

I had this problem across multiple tables, because of the crap schema, and in the end I had to take the tables out of the DB in to another file, and copy the structures of the tables, then amend the data types to 'memo' and then append the data to the new tables.

During the process, I had to run Compact and Repair multiple times, because an error stating that the number of columns I had exceeded 255.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.