Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got an iPhone 3G. I'm with AT&T.

Using both official and custom firmwares, I'm unable to start Internet Tethering. When I turn it on, nothing happens. No blue bar appears over the top of the phone.

I've installed the custom AT&T profile from help.benm.at, and it has not worked. I've also used the Gizmodo IPCC file with the terminal command to enable carrier testing - nothing has worked.

Anyone have a brilliant idea as to why tethering will not start?

share|improve this question

2 Answers 2

up vote 5 down vote accepted

Simply turning on tethering in the preferences doesn't turn on the blue bar - you have to connect it with a computer via Bluetooth or USB for it to work. Seeing as you've tagged this "osx", I'm assuming that you have a Mac.

The most reliable way to get my phone to tether is with USB. The first time you connect it with tethering enabled, your Mac should tell you that it detects a new network device, and will ask you if you want to configure it. The default settings (automatically get address via DHCP) are fine, and it should begin to tether.

If this does not happen, you could try Bluetooth, but there have been issues with the unibody Macbooks and the iPhone Bluetooth tethering, but it's worth a shot. To do this, you have to select "Set up Bluetooth device" under the Bluetooth menu in the top bar. When it asks you what kind of device you're setting up, you need to select "Any device". The iPhone does not show up if you select "Mobile phone".

At this point, you need to turn on Bluetooth discovery on your iPhone - this is accomplished by navigating to the Bluetooth preference pane in Settings - you will see "Now Discoverable" at the bottom. Your Mac should see your iPhone as a Smartphone, and after you bond the two you can select "Use device as a network port" and complete the setup.

Now, when you go to the Bluetooth menu in the top bar you will see your iPhone, with a submenu item to "Connect to network". Selecting this should be enough to get it to tether. (This may take a few tries).

At least, this is how it's supposed to work. Can you be more specific about which step you're stuck on?

share|improve this answer
    
I personally find that bluetooth doesn't work too well, but great advice on the USB connectivity! –  Alexis Hirst Aug 1 '09 at 22:29
    
Sorry for the delay in accepting. I was having problems because I was not selecting "Any Device" when setting up via bluetooth. Cheers buddy! –  EvilChookie Aug 3 '09 at 23:44
    
+1, great answer. Bluetooth doesn't work reliably for me either, it just craps out at random. USB, on the other hand, has been excellent. –  Pauk Aug 8 '09 at 20:17

Maybe it's obvious - but I didn't figure it out for a while..
Tethering didn't work for me until I had established the 'upstream' internet connection (Cellular/3G) before enabling tethering. Simply trying to get a LAN happening via tethering without the internet connection wasn't happening for me.

Perhaps this might help someone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.