Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At some point the fingerprint reader on my Lenovo Tablet PC (X41, running XP) quit working. The login screen still says "press ctl-alt-del or swipe finger", but swiping a finger no longer does anything.

Configuration software appears to be all in order, except if I go in to re-enroll my fingerprints it throws a "An internal error occurred (rpnp2: br-conn).

Updating the Lenovo software hasn't helped.

Any thoughts on how to get this going again?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

You have the correct Lenovo software installed, I'll assume? Go into the Tutorial in the FPR app and you can actually test the scanner at will to see if it's actually working.

Go into the machine BIOS and clear the security chip and then attempt to reenroll fingerprints again; it's possible that the security hash table is corrupted or something of the sort.

It could potentially be that the internal connector is coming unseated, but an X41 Tablet is probably more complicated to disassemble than most people are willing to try (unlike most ThinkPads where most components are easily user-serviceable). If you're technical, I'd recommend going to the Lenovo site and looking for the Hardware Maintenance Manual for that machine model type number because it's worth a try.

If none of that works, it's probably just a hardware failure. This is a pretty old machine, and the build quality is obvious if it's lasted you this long with no problems! Good excuse to upgrade to an X201 Tablet. :)

share|improve this answer
    
I should probably clarify that IBM was responsible for the X41T, not Lenovo...it was one of the earlier machines Lenovo built. It's pretty old! They're built like little tanks, though...love them. –  Shinrai Jul 27 '10 at 14:15
    
I'd love to buy a new Lenovo Tablet, but last time I checked they were listed as backordered (to the point that they weren't even accepting new orders). –  Brian Knoblauch Jul 27 '10 at 14:21
    
They were having trouble getting some of the processors, believe it or not; the X201T is listed again on Lenovo's site and has been for a while. Build times are variable but I believe generally under a month. Let me know if you're able to get the X41 working though! –  Shinrai Jul 27 '10 at 14:24
    
Looks like a software issue. The machine BSoDs when trying to bring up the fingerprint configuration software (but is completely reliable otherwise). :-( –  Brian Knoblauch Jul 30 '10 at 19:53
    
I have never seen that specific behavior before and therefore I would hesitate to pin it on software alone - typically you get a verbose error message if there is a problem communicating with the FPR or bad drivers or what have you. The way to confirm would be to try with a clean format (pretty straightforward if you have a spare hard drive) but I would be moderately surprised if that actually worked. Does the FPR show up normally in Device Manager (should be under Biometric Devices)? –  Shinrai Jul 30 '10 at 21:50
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.