Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can the font size be changed in Notepad++?

I just downloaded and installed Notepad++ v5.4.5 (I have been using UltraEdit for the last 11.5 years) and can not find a menu command for changing the screen font. I want to change it to Lucida Console 18pt.


Other notes: to download Notepad++ go directly to the SourceForce download page for Notepad++.

share|improve this question
7  
The Notepad++ configurations are all highly non-intuitive. It's disgusting that "How do I change the font?" in a rich-UI windows text editor needs to be asked and upvoted two-dozen times. –  Joe Coder Mar 14 '13 at 21:52
1  
Agreed. Notepad++ configuration options suck. The max font size there is 28. Why on earth the max is set to 28? –  Tem Pora Nov 5 '13 at 10:05
add comment

9 Answers

Ctrl and NUMPAD +/NUMPAD - or mouse wheel to zoom in/out

Edit: Or to achieve exactly what you asked for...

Settings > Style Configurator. Under Font Style you can set the font and size

share|improve this answer
    
while answering, how do you get the Ctrl in a box?? –  Lazer Sep 16 '09 at 19:15
11  
Type <kbd>key</kbd> –  Ciaran Sep 17 '09 at 0:43
add comment
up vote 21 down vote accepted

Open menu Settings/Style Configurator. Then with the default theme "Default (styles.xml)" and default language "Global Styles", change the font name and font size for style "Default Style" (the default, style "Global override" will not cut it).

If a document is already open then the display will change immediately as the font name and font size is changed - nice touch! Press the "Save & Close" button to keep the new settings.

Note that in Notepad++ 6.0, you will also need to check the enable global font and enable global font size check boxes.

share|improve this answer
add comment

Alternatively, hold Ctrl and use the scroll wheel of your mouse.

share|improve this answer
    
How can this change the font to "Lucida Console"? –  Peter Mortensen Oct 4 '13 at 14:12
add comment

Fonts and styles can be changed in the Style Configurator.

  • Settings
  • Style Configurator
share|improve this answer
add comment

With 5.9.4 I have found that the global override does cut it, as zooming seems to influence global and language-specific font settings differently so that whitespace has different sizes (Tabs don't line up with different zoom levels). The font size did not seem to change either..

share|improve this answer
1  
So... is this a fix to the problem or..? –  Simon Sheehan Dec 5 '11 at 21:02
add comment

(Notepad++ 6.1.1)

I'm not sure about you, but to me this feature should be in Preferences. I totally missed it when it was right underneath it :p.

Anyway, you could kill two birds with one stone by changing the theme.

Change font & Chose a dark background:

  1. Go to Settings on the top menu
  2. Chose Style Configurator...
  3. At the top it's the theme selector Select theme

Notepad++ has many themes to choose from, so if you're one of those that likes to code on a dark background with a san-serif font the Ruby Blue theme is a good choice, it works great for me.

My 2¢.

share|improve this answer
add comment

Settings>Style Configurator>

Font Style: Font Name Font Size

Then check 1. Enable global font 2. Enable global font size

Then click on "Save & Close" button.

share|improve this answer
add comment

Scroll the mouse wheel up while pressing Ctrl...

share|improve this answer
    
This changes the display size but doesn't actually sent a typeface or font size in the document. –  kmarsh Mar 11 at 14:37
add comment

Ctrl + F12 will give you all authorities to change the appearance, background, foreground, fonts etc. !

share|improve this answer
1  
Gaurav, what is Ctrl + F12 supposed to do? It does nothing on my installation, Notepad++ v. 5.4.5. For instance, is there a corresponding menu command? –  Peter Mortensen Sep 17 '11 at 9:46
2  
Agree, CTRL+F12 does nothing. Please revise your comment. –  Ricardo Aug 16 '12 at 18:38
    
Its the year 2014 and Ctrl+F12 is still not doing anything. –  madLokesh Mar 11 at 10:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.