Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently using Google Chrome and I run into a problem searching:

Whenever I type something like "Google Chrome" into the address bar, I mean to say, "Search for Google Chrome". However, Chrome by default thinks I'm asking it to Google just the word Chrome.

Any way to disable this, just for the word Google?

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

I know this is old, but if anyone is still running into this, you can disable it in current versions of Chrome:

  1. Go to Chrome Settings (chrome://settings or click "Options" in the menu)
  2. On the Basic tab, in the Search section, click the Manage Search Engines button
  3. Under "Other Search Engines", remove or rename the Google Quicksearch entry
share|improve this answer
    
this is the correct answer to the question. Thanks. This has been really annoying me for the past few months but too lazy to find out how to turn this off. –  Belliez Sep 14 '12 at 12:43
add comment

I could think of two methods:

Explicit search

The address bar can be put into "search mode" by one of the following:

  • Ctrl + K
  • Type "?" as first character

Everything thereafter will be searched for.

Change Google keyword

What you describe is usage of keywords, they used to make a quick search using another search engine. For example I use "wp Trees" to search for trees on wikipedia and "ud Tree" to search UrbanDictionary for the same.

In your case "Google" is the keyword for search using google. Change it in Settins->Basic(first Tab), find the header Search, click on the "Manage" button and you will be presented with a list of search engines to edit.

You can see that the keyword is in effect after typing the keyword, space and the first letter in your search, the addressbar left side changes to a blue frame around the search engine.

share|improve this answer
add comment

You can put it in quotes:

"Google Chrome"

Put chrome first (it's the same query):

Chrome Google

Or use the + operator to require the term:

+Google Chrome

share|improve this answer
    
+1 - deleted duplicate post –  JNK Jul 27 '10 at 15:02
    
Does that mean there's no way to disable it without typing extra? –  Chris Jul 27 '10 at 17:34
    
/reordering? I'd like to update it if there's a setting available. –  Chris Jul 27 '10 at 17:49
    
@Reckage - I'm not aware of any setting for this, but then I haven't dug that deep to find one. If someone else posts such a setting, that's probably a better answer. But failing that, I think this is probably the best you can. –  Joel Coehoorn Jul 27 '10 at 18:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.