Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Notepad++ 5.4.3 and I have Google Chrome installed.

In Notepad++, I know I can click on the Run menu; then browse for the .exe. But unfortunately, the only chrome.exe file I can find seems to be for the chromeframe for Internet Explorer.

Also, how can I remove the "Chrome" shortcut (which is not working) which I have added to the Run menu?

share|improve this question
up vote 7 down vote accepted

If you download the latest version (5.7?), the Run Menu has four different "Launch in browser" menu items (IE, Firefox, Chrome, and Safari)

share|improve this answer
    
@A Donahue, Thanks. I might do that later. – systemovich Jul 28 '10 at 18:20

You can edit the link in the run menu by going to the %AppData%\Notepad++ directory and editing the shortcuts.xml file to reference the proper location of Chrome.

<Command name="Launch in Chrome" Ctrl="yes" Alt="yes" Shift="yes" Key="82">chrome &quot;$(FULL_CURRENT_PATH)&quot;</Command>

Thats what it reads by default

<Command name="Launch in Chrome" Ctrl="yes" Alt="yes" Shift="yes" Key="82">%LocalAppData%\Google\Chrome\Application\Chrome.exe &quot;$(FULL_CURRENT_PATH)&quot;</Command>

That's what it could read

Type this into the run command box:

%LocalAppData%\Google\Chrome\Application\Chrome.exe "$(FULL_CURRENT_PATH)"
share|improve this answer
    
I get the access denied error, even though I have closed Notepadd++. Also, the links that I added to the Run menu inside Notepad++, do not appear in the xml file. Maybe I could copy the contents of the current shortcuts file to a new one and delete the current one. – systemovich Jul 27 '10 at 17:39
    
You get access denied error when trying to edit "C:\Program Files\NotePad++\shortcuts.xml"? Close notepad++ edit the shortcuts.xml file to what you want to have appear then open notepad++ and everything should reload fine. – jer.salamon Jul 27 '10 at 17:52
    
If you get 'access denied' when you try to edit shortcuts.xml, how do you know that the links you added are not in the file? Are you logged in as a restricted user? Try logging in as an admin. The links you entered in Notepad++ are probably in Settings > Shortcut Mapper > Run commands. – boot13 Jul 28 '10 at 14:50
    
@boot13, I can open the file and edit it, but I cannot save my edits, because of that "access denied" popup. I am logged in as admin. – systemovich Jul 28 '10 at 18:09
    
@jer.salamon, I copied this C:\Documents and Settings\user\Local Settings\Application Data\Google\Chrome\Application\chrome.exe&quot;$(FULL_CURRENT_PATH)&quot; into the Run dialog, but nothing happened. Should I perhaps replace the &quot with something else when I paste it into the Run dialog? Thanks. – systemovich Jul 28 '10 at 18:14

Try adding the shortcuts you want in Settings > Shortcut Mapper > Run commands.

share|improve this answer
1  
thanks. Now I could at least delete the nonworking shortcuts that I added. – systemovich Jul 28 '10 at 18:10

In later verions of Notepad++ (currently 6.6.8) the shortcuts for browsers are not set by default, so one needs to save them first. To do so you can:

  • Add them manually from Run menu
  • Edit shortcuts.xml file

For the step by step solution, you can visit this link.

share|improve this answer

I made the shortcut to be Alt + Shift + R and all is working fine.

The same for the other browser shortcuts.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .