Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a very strange problem with my wireless routers, or linux. I have 2 wireless routers one directly connected to my modem (router 1) and another wireless router (router 2) on the 2nd floor connected to router 1 without cables and configured as a repeater bridge. Router 1 is configured to broadcast the ssid and have been set up to use wpa-personal and router 2 has the same configuration as router 1 plus a virtual interface. I am able to connect to both routers from all my windows boxes, but I fail to connect from linux (I have tried with 2 different laptops without luck). What is very strange is that I can't see the routers when I scan but I am able to see my neighbors routers. I have tried to turn off router 2 to see if it had an impact, but no luck. I know that I am able to connect to a wireless router since I have had success with that at work.

Router 1 is a Siemens se551 (with default firmware) and router 2 is a linksys wrt54g (running DD-WRT build 13064).

Hope that someone can help, so that I can install linux on my new netbook and get rid of Windows 7 starter . . .

share|improve this question
    
Some more detail such as Linux distro / version would be helpful. –  Nathan Osman Jul 27 '10 at 20:38
    
Well I have tried with different linux distributions, suse 11, ubuntu 9.x, kubuntu 9.x and 10.x and kubuntu 10.x for netbook. It seems as if the fact that I have connected to the router from Windows from the same machine has an impact. –  user44313 Jul 28 '10 at 6:39
add comment

migrated from stackoverflow.com Jul 27 '10 at 20:28

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 1 down vote accepted

I solved the problem after installing kismet on the computer and analyzing the results. I found that the routers were set to use channel 13 (it was set to automatic) and an iwlist wlan0 channel reviled that channel 13 was not available. I changed the channel to 1 and now it all works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.