Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 64-bit, and I've mounted my previous computer's Vista 32-bit hard drive through an external enclosure so that I can access my files on my new computer. I can access every part of the drive except my old User folder (C:/Users/John).

When I attempt to access it, it prompts me for the administrator password (which it didn't need for any other part of the drive) and then loads infinitely.

http://i32.tinypic.com/hrgajc.png

Letting it load doesn't seem to do anything. The harddrive is constantly working but nothing is happening. I find it extremely strange that it's just the E:/Users/John folder I can't access, but it doesn't even work when I run as Administrator.

Any help?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The problem here is that the drive is formatted as NTFS, which supports permissions, and your user account is locked down to PreviousVistaMachine\john, which is NOT going to be the same SID as NewWindows7Machine\john, so it's rightfully telling you "Access Denied".

To fix it:

  1. Click on the folder, right click it and choose properties.
  2. Click Security.
  3. Click Advanced.
  4. Click the Owner tab.
  5. Click Edit.
  6. Click your name.
  7. Check the "Replace owner on subcontainers and objects".
  8. Click Ok.

After that, you might still need to go into the security tab and grant yourself rights to the folder - but try it first and see.

Good luck!

share|improve this answer
    
Worked perfectly. Had to set privileges as well, but that was exactly what I needed! Thanks! –  GuyNoir Jul 28 '10 at 5:40
    
Happy to help! I've had this exact problem before, so I knew right away what it was. :) –  Mark Allen Jul 28 '10 at 18:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.