Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The System->Preferences->Sound have no option for that..

(using ubuntu 9.10)

--update for @JonT

Mycustom.config file:

[daemon]

[security]

[xdmcp]

[gui]

[greeter]

SoundOnLogin=false

[chooser]

[debug]

[servers]

share|improve this question
    
The what sound? –  Ignacio Vazquez-Abrams Jul 27 '10 at 22:04
    
@Ignacio the sound made when you login –  Tom Brito Aug 1 '10 at 0:45

5 Answers 5

up vote 3 down vote accepted

Go to System->Preferences->Startup Applications. Uncheck GNOME Login Sound. That'll disable the sound you get when you log in.

share|improve this answer
    
Unmark it didn't worked (as I logout and login it get back marked). But remove it worked, thanks! =) –  Tom Brito Aug 28 '10 at 17:58

Can't remember exactly, but I think it's in "Login Screen" and/or "Appearance" section.

share|improve this answer

Its in: System->Administration->Login Screen->Check box(Play login sound)

share|improve this answer
    
did you find it? –  jer.salamon Jul 29 '10 at 12:23
    
hi, there's no such checkbox here.. –  Tom Brito Aug 1 '10 at 0:44

If you're referring to the sound on the login screen, open up the file /etc/gdm/custom.conf and under the [greeter] section, insert this:

SoundOnLogin=false

you will probably need to open the above file with sudo, so use sudo gedit /etc/gdm/custom.conf or it will not allow you to save.

You can turn off all Ubuntu event sounds with gconftool:

gksudo -u gdm gconftool-2 –set /desktop/gnome/sound/event_sounds –type bool false
share|improve this answer
    
I believe instead of sudo gedit /etc/gdm/custom.conf it is more Linuxxy to use gksu gedit /etc/gdm/custom.conf (as sudo is for console commands, while gksu/gksudo/kdesu are for X/graphical applications). –  chronos Aug 23 '10 at 11:12
    
@chr You will see the same result as long as you've entered the sudo password within the grace period. –  John T Aug 23 '10 at 12:08
    
@John - I thought it was considered bad to use sudo for graphical applicattions - something to do with creating files that are owned by root and cause problems later??? –  Andy Aug 24 '10 at 14:58
    
@Andy can you point me to the source of where you got this information? Because it's entirely wrong. gksudo will present you with a graphical dialog asking you for your password as opposed to sudo which asks you for it on the command line. It doesn't create any files. –  John T Aug 25 '10 at 0:04
    
@John I agree with you, but also found there are certain cases where this is a problem (psychocats.net/ubuntu/graphicalsudo). I use sudoedit filename in any case. –  invert Aug 25 '10 at 10:44

I think you can use Ubuntu Tweak for that. It's easy to install and you can disable the start-up sound with a GUI.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.