Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Python on my Windows 7 (64-bit) - AMD Sempron Machine. I downloaded the 3.1.2 Windows X86-64 installer. After running it and selecting the option to install it for all users, the installer window disappears. Eventually I get a dialog box error back that says "Installer is no longer responding".

I've also tried the x86 version and the 2.7 amd64.msi. Any reason why I'm getting this error?

share|improve this question
    
Are you able to install other MSIs? If not, it's probably an issue with msiexec – Velociraptors Jul 28 '10 at 5:38
up vote 3 down vote accepted

Did you try to install by right clicking on the installer and selecting "Run as Administrator"?? Even if you disable User Account Control, you still have to run some installers "As Administrator".

share|improve this answer
    
The option to run as administrator doesn't appear in the right-click context menu and is grayed out in properties. I've also tried running in compatibility mode. Unfortunately the issue remains. – Mike B Jul 28 '10 at 17:34
    
I also checked my permissions in Windows and I'm a member of the Administrators group. – Mike B Jul 28 '10 at 17:34
1  
Try completely disabling UAC. – James Watt Jul 29 '10 at 16:17
    
Bingo. Disabling UAC did the trick. Thanks! – Mike B Jul 29 '10 at 17:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .