Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the following network setup:

Netgear     <-->   Netgear HDX111    <--> Apple Airport Express
router          (ethernet over power) 
(192.168.0.1)                                 (192.168.0.9)
                                              DHCP: 10.0.1.2-200

I'm using the Airport Express (AE) for wireless access in my living room and music. The music is streamed from a computer plugged into the router to the stereo plugged into the AE. I want to use Apple's Remote app on my iPhone to control the music on the computer. However, the network created by the AE is in a different address space so iTunes can't see it.

Using the manual setup in Apple's AirPort Utility program, I can change the beginning and ending DHCP addresses (AirPort Utility -> Internet -> DHCP). The Netgear router has its DHCP space set up to allow addresses between 192.168.0.2 - 192.168.0.51. Be default, the Airport Express is on 10.0.x.y; I'd like it to use the space of 192.168.0.100 - 192.168.0.200. When I do this, AirPort Utility reports "The DHCP range you have entered conflicts with the WAN IP address of your Apple wireless device."

With my laptop, I can connect to the shared drives on my computer (laptop [ip: 10.0.1.2] connecting to a folder on the PC [ip: 192.168.0.3]) so I know I can see my machine through the network.

Versions:

  • AirPort: 6.3
  • iTunes: 8.2.1.6
  • Remote app: 1.2.1 (11)

Is there a way to have my wireless devices connected through the AE in the same IP range (192.168.x.y) as the rest of my network?

Or, is there a way to get iTunes to look across an IP range for the Remote software?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

You want to configure your Airport Express as an access point, not as a router. I've configured my Airport Extreme to do something similar, so I hope that these instructions work for you.

  1. Open up Airport Utility
  2. Select your Airport Extreme, click "Manual Setup"
  3. On the top, select the "Internet" tab
  4. At the bottom of the "Internet Connection" tab, go to the preference labeled "Connection Sharing"
  5. Select "Off (Bridge Mode)"

That should enable devices connected to your Airport Express to get their addresses from your main router, and for all the devices to be on the same subnet and communicate with each other.

screenshot of setting location

share|improve this answer
    
Awesome! That was amazingly easy. I've tried so many different configurations I don't know how I missed that one. –  dwj Aug 1 '09 at 18:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.