Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've finally taken the plunge and ditched Vista for Ubuntu 10.04, and have a strange problem when booting up.

Normally, my boot disk is /dev/sda, and grub boots from /dev/sda1 just fine. Once Linux has started, if I plug in my USB disk it is automatically mounted as /dev/sdb, and again, everything is peachy.

The weirdness happens if I try to boot with the USB disk plugged in. For some reason, the USB disk is detected as /dev/sda, and my internal disk is detected as /dev/sdb. Grub then fails to start, giving error code 17, because there's no boot partition on /dev/sda.

Is there any way I can control how these disks are detected whn the system starts up? If it helps, the laptop is a Sony Vaio VGN-AR51E

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Check your BIOS settings. There may be a way to control how devices are detected. Also check your boot device order and similar, if you have such settings available.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.