Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have most of my audio files on a system shared by most of the people in my family, and i'd like to be able to get them accessable to a headless linux box i control over smb. The share(s) in question are not on a share that requires authentication (and most examples assume so), and i'd like to have them automatically mounted, and accessable on boot.

I'd like to only use command line tools - so anything that has x dependancies is out, and shares should be accessable to any user on the system via a mount point

OS shouldn't matter, but the "fileserver" is a windows XP system, and i can access the shares without logging in, and the client is a ubuntu 10.04 lts system with a minimal CLI install.

share|improve this question
    
Is the Windows XP "fileserver" a Home or a Professional variant? –  Kurt Pfeifle Jul 31 '10 at 10:58
    
professional. I can access the file share from another windows XP system without logging in. –  Journeyman Geek Jul 31 '10 at 11:46

1 Answer 1

up vote 0 down vote accepted

On your Ubuntu 10.04 add a line to /etc/fstab telling your system to mount the remote WinXPProf share.

  1. Create the mountpoint:
    mkdir /mnt/winxp.
  2. Add the line to fstab:
    echo "//windowsserver/sharename /mnt/winxp smbfs auto" >>/etc/fstab

This will auto-mount the remote share sharename on remote server windowsserver at boottime. Also, the commands mount -a or mount /mnt/winxp should re-mount that share, should the mounting have been lost for some reason.

For this to really work on WinXPPro, make sure the security settings [*] for the shared directory allows the guest user as well as the everybody group allow at least (depending on your requirements) read permissions.


[*] Right-click the foldername in explorer, select "Properties...". Go to the "Security" tab to add the "guest" user and the "everybody" group. Don't forget to click on the "Extended" button and make sure the NTFS permissions do allow the desired access for guest and everybody as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.