Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Starting with Ubuntu 10.04 I have flickering in darker areas of the screen with my HP Compaq nc6400 notebook. This happens with Ubuntu 10.04 with 32-bit as well as with 64-bit default installation (no manual X-windows configuration). Never had this problem with Ubuntu 9.04 or 9.10.

Running lspci outputs:

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc M52 [Mobility Radeon X1300]
02:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
02:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
02:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller
02:06.4 Communication controller: Texas Instruments PCIxx12 GemCore based SmartCard controller
08:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5753M Gigabit Ethernet PCI Express (rev 21)
10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

Maybe the most important line is

01:00.0 VGA compatible controller: ATI Technologies Inc M52 [Mobility Radeon X1300]
share|improve this question

4 Answers 4

It may well be a driver issue. Have you tried installing a driver for this card yet? According to what I have read your exact card is no longer supported under the official driver releases from ATI. That said there is an open source alternative that seems to have worked for a good chunk of people over on the Ubuntu forums. I would post all the instructions here but there are so many steps that I will instead post some links for you:

Thread about problem with ATI 1300
Community guide for installing opensource driver
2nd Community guide for installing opensource driver.

Let us know how you get on with these or if this helps.

share|improve this answer
    
Thank you for the hint. I'll summarize the step I did in a separate answer. –  Mike L. Jul 28 '10 at 12:20
    
no probs. Have just spent the weekend trying to get ATI drivers working on ubuntu 10.04. Sometimes it works sometimes it becomes troublesome. still thats the joy of linux! let us know how you get on –  Tim Alexander Jul 28 '10 at 12:21
up vote 3 down vote accepted

I needed to create the file /etc/modprobe.d/radeon-kms.conf, add following line

options radeon modeset=0

and had to restart. Now flickering is gone. :)

share|improve this answer
    
this is probably the related bug entry: bugs.launchpad.net/ubuntu/+source/linux/+bug/543045 –  Jukka Matilainen Jul 28 '10 at 17:18

It seems something is wrong with the ATI 1300. I found something to do in order fix this problem:

In my case I added a command to the kernel:

radeon.new_pll=0

To do this we must to edit the file /etc/default/grub

sudo gedit /etc/default/grub

And in this line:

GRUB_CMDLINE_LINUX=""

We put the additional line command:

GRUB_CMDLINE_LINUX="radeon.new_pll=0"

And finally we must to run the command grub2 typing this in order the changes be done:

sudo update-grub2

May be you have to re-start your system.

Thanks to Geek Cesar

share|improve this answer

I've solved this problem. Follow the steps that I mention here:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/665233/comments/7

Remove everything that has something to do with the graphics environment, as it says in the Ubuntu wiki page.

Then,

$ gksudo gedit /etc/default/grub

And change this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to this one:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset acpi_backlight=vendor"

Then

$ sudo update-grub

Reboot and be happy. Desktop effects work too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.