Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

No help from Google or Microsoft - so I'll ask some experts. All solutions I have tried are below.

When I put a CD in the computer, or plug in a USB flash drive, I don't get a window asking me what I want to do (play music, open folder to view files, nothing, etc.) I tested the USB drive on my other computer, and I get the dialog.

The devices show up in My Computer. If I right click and select properties, auto-play is enabled for all file types.

Microsoft suggestions tried: http ://support.microsoft.com/kb/330135
1. Roxio Easy CD Creator is not installed.
2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom Autorun = 1
3. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer NoDriveTypeAutoRun = 91
4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon allocatecdroms = 0
5. The ASUS DRW-014L1T cd/dvd drive has the latest drivers, and is compatible with XP.

Microsoft autoplay repair wizard: http ://www.microsoft.com/downloads/details.aspx?familyid=c680a7b6-e8fa-45c4-a171-1b389cfacdad&displaylang=en#Instructions
1. Downloaded and ran autofix - if reported a repair, and said to reboot. No change. Ran tool again, now it says it already ran, and I need to log on/off before running it again. I logged off/on and also rebooted several times, and I still get this message.
THIS TOOL IS BUGGY!

Googled suggestions not redundant with the above -

The Microsoft tool APPMDiag is supposed to do a postmortem report on it's last autoplay when you remove a device - nothing appears in the window when I take out a USB flash drive or a music CD.

Running gpedit.msc (to open the Group Policy window) :
1. Local computer policy - User configuration - Administrative templates - System - Turn off autoplay = disabled
2. Local computer policy - Computer configuration - Administrative templates - System - Turn off autoplay = disabled

Any other ideas?

share|improve this question

1 Answer 1

The only thing I can suggest is that you try PowerToys TweakUI from http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx. In the My Computer -> AutoPlay section there are numerous options, some of which no doubt use the same registry keys as you have mentioned. If that doesn't work then I guess there must be something wrong with your XP installation.

share|improve this answer
    
I got that working for my USB drive. The CD still won't autoplay. I'm not spending more time on this. –  Eric54 Sep 6 '10 at 19:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.