Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was able to edit Database projects in my installation of VS2010 ultimate. However per project requirements I had to uninstall SQL Server 2008 and install SQL Server 2008 R2. Now I have lost the ability to open sql files in VS2010 IDE. Whenever I double-click on a .sql file to open the script file, I get an "Object reference not set" error. Looks like the extension to edit SQL files in VS2010 has been removed.

How do I reinstall the T-SQL editor extension?

Have tried repairing both VS2010 and SQL Server 2010

Thanks

share|improve this question

2 Answers 2

Have a look at this post

http://social.msdn.microsoft.com/Forums/en/vssetup/thread/27ef7c94-4410-4925-ab22-3fec475b1885

To fix the issue of not being able to load the RadLangSvc.Package here is what you need to do:

  1. Load up your ISO or DVD VS2010 Installer in an explorer window
  2. Go to the WCU foldler
  3. Go to the DAC folder
  4. Install MSI's

    i. DACFramework_enu.msi
    ii. DACProjectSystemSetup_enu.msi
    iii. TSqlLanguageService_enu.msi

share|improve this answer
    
Link-only posts are frown upon because they can go stale. You should copy the relevant parts just in case. –  Synetech Dec 7 '12 at 7:05

Look for "Restore File Associations" under Tools > Options > Environment. I don't have VS in front of me but I've used that in the past.

share|improve this answer
    
unfortunately that did not fix the issue. Thanks for the answer. –  Rams Jul 29 '10 at 1:19
    
In that case, though it's an extreme measure, I'd reinstall VS 2010 from scratch, like you did with SQL Server. Obviously there's some arcane magic Microsoft uses to associate .sql files with 2008 R2 :-). –  user3463 Jul 29 '10 at 1:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.